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Introduction
WXtolmgis fully automated weather satellite recording, decoding, editing, and viewingasafiivXtolmg
supports mapwerlays, advanced colour enhancements, 3-D images, animations, multi-pass images, projec-
tion transformation (e.g. Mercator), textedays, automated web page creation, temperature disoldy
control for may weather satellite recars, communications recars, and scanners.

WXtolmgsupports both APT transmissions from polar orbiting satellites andAERnsmissions from
geostationary satelliteswXtolmghas a built in set of image processing facilities, but can output ra
images for further processing. Output is in JPEG, PNG, B8R (PGM/PPM/PNM), or AVI format.

WXtolmgattempts to produce reasonable images fromwesewhich hae o narrev an IF tandwidth
(e.g. scanners) although there are limitations on what can be done.

WXtolmguses the telemetry data on NOAA APT imagesely\accurately calibrate the image, correct for
non-linearities in signal strength, and raakljustments for gain changes across the pass. The telemetry
data is also used to calibrate the instruments to provide for very accurate temperature readings.

On GOES satellites, the grayscale is used to correct for non-linearities in signal strength and normalise the
image. Accuratéemperature calibration on IR images is also performed.

On other satellites, the grayscale and black and white bars are used to adjust the gain.

WXtolmguses a PLL technique to correct for doppler shift and ensure straight imagednsisitllites
evan in the presence of very high noisedis or poor signal qualityA burst cycle PLL is used on Meteor
and Resurs satellites to correct for doppler shift and to help ensure the images are straight.

Status and Information Lines
Across the top of the WXtolmg display arevaral tabs (Image, Audio Files, Ralmages, and Sad
Images). Upgradedersions will also hee Composites, and AnimationsThe first tab (Image), is
WXtolmg’s main display This is where decoded images will be shown and where the image will be dis-
played while recording All the other tabs sl thumbnails of audio files, vaimages, sad images, or
animations that were created by WXtolmygote that images or audio files manually copied into WXtolmg
directories will not be stvan. Clickingon a thumbnail will open the associated filehis provides an easy
means of reviewing a day{or week’s, or month’s) satellite passes.

At the top of the WXtolmg Image screen, gbdhe image, is the information linévhen an image is dis-
played, the information line will display the satellite name or type and the date and time (in UTC) at which
the image bgins. For APT satellites, the satellite direction ofvigg maximum elgation (in degrees albe

the horizon) and azimuth (E or W) at maximunvaien will be shown whenwilable. For NOAA APT
satellites, the tev channels will also be gén. For WEFAX images, the digital header information will also

be given in parenthesis (whervailable).

At the bottom of the WXtolmg screen, belthe image, are twgatus lines. The bottom line indicates the
processing that is being performed, shows warnings and sometimesTtiatop status line is divided into

a rumber of sections, the leftmost sectionvghdhe current UTC timeTo the right is the sub-information
line, this usually shows the satellite \v&lton and azimuth along with image coordinates under the gursor
but while recording will shar information about the recorded sateltéjcation, and at certain times other
information may be shen. Next, to the right, is that latitude and longitude display -- when the cursor is
over an image that has an associatedrtay map this will shw the latitude and longitude (WGS84) under
the cursar Next is the distance displaghowing the distance from the ground station location to the loca-
tion under the cursorldust to right of this is the temperature indicatidhen displaying NOAA or GOES
images, the temperature under the cursor is displayed in this section. The units of temperatarek()C, F
may be changed und&Ul Optionsin the Optionsmenu. D the right of the temperature indicator is the
seconds into recording displayhis gives the number of seconds into the recording under the culitsier
especially useful when usirartial Decodeto determine which part of a signal to decodé&e rightmost
section gies the volume used when decoding the image. During recording it showsltimey Normally

the recerer volume should be adjusted so the volume shows between 50.0 and 7RRedeaxd Caliba-

tion under theHelp menu for more details).
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File Menu
This menu is used to select the file to decode and the filename when saving images. It also is used to start
the decode process.

Open Audio File...
Selects an audio file for subsequent decodiBgcoding will start automatically as long as
Disable auto-decodés not selected in th®ptions menu. Audioinput files may be in either
AU (.au), WAVE (wav), or raw (8-bit unsigned or 16-bit signed LSB) format. The files must
be encoded in linear PCM format at 11025 samples per seé&otiebr 8, 16, or 32 bits per
sample is acceptable, but 8 bits per sample recordiog®tcontain enough information to
produce good quality images. 16 bits per sample is highly recommended. Audio files should
be mono.If a stereo (or multi channel) audio file is used the program will ignore all but one
channel. lis strongly recommended that only mono audio files are used.

Open Raw Imge...
WXtolmgcan read na images inPNG, PBM (PGM), or NOA formats. Thisconsiderably
speeds up the processing tinveraeading in the audio filesDecoding will start automatically
as long adisable auto-decodeds not selected in th®ptions menu. NOA format files are
produced by some satellite receiving systems. These images should generally be W6 bit ra
grayscale images. ImagesJREG BMP, AVl or other formats cannot be read by WXtolmg.
Note that theResyng Interpolate, and Disable PLL options and the sampling rate settings
have ro afect when processing these imagé@$ese settings apply only when audio files are
decoded.

Save Imge &...
Saves the currently displayed imagé&.he output format (JPEG, PNG, BMPNM, AVI) used
for output is specified by the filenameension. Ifyou do not use arx&ension, or thexden-
sion does not relate to one of the supported output formats, the default will be the format set in
thelmage and Movie Options..under theDptions menu.

Composite Imge ...
Saves the currently displayed image to the fileagi. If the current file exists and yowes-
write it, then (similar to the AVI transparency) the file will be updated so that the original
image will only be werwritten where the current image contains valid satellite data. By select-
ing a projection other thaNormal and setting theProjection Optiondo a wide area around
your location, an image using multiple satellite passes may be built up.

Save Raw Inge ...
Saves the 16 bit rav image in PNG formatRawv images are useful as thean read using
Open Raw Image..and can be processed to produce all the different enhanceretsthat
the Resyng Interpolate, and Disable PLL options and the sampling rate settingsehao
affect when processingwamages.

Mixer Control...
Launches the mix control used to select the input source, and recording and monitoking v
umes when recording.

Record... Starts the recording procesallows selection of whether the image should be decoded, and
whether the audio file and/orwamage should be ged. Alsoallows for a series of images or
movies to be created. These settings are also used fAuthérocesscommand. Theptions
for which enhancements should be generated and the filenames for imagevigsdcarobe
set by clicking on the associated settingstdns. Sedhe Filename &mplatesection for a
description on he filenames are chose®ther aspects of the recording process (e.g. bits per
sample) and whether recording is squelch or satellite pass based can be changed under
Recording Options...in the Options menu. Therecording (and decoding) process repeats
until it is stopped by selectingtop from theFile menu. TheMinimum percent of @jection
filled setting (upgraded versions only) disables théngaof images and adding of wie
frames where the resulting image has less than the selected percent of pixels filled. Note that
images are ner saval if the projection had no pixels filled. The default is 0.1%he
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Minimum solar eleation for visible imges setting (upgraded versions only) disables the sa

ing of images which makuse of visible light sensors on the satellite and where the centre pass
solar eleation is less than the setting. The default of 0 specifies that images shoulcde sa
regardless of the solar eletion.

Recod only (show imge i enabled)

Records satellites according to the settingRésoding Optionsunder the options
menu. Anunprocessed image will be shown while recording if enable@dUh
Options Does not perform additional processing. These recordings may be later
decoded by usin@open Audio Fe under theFile menu or by clicking on the
thumbnail in theAudio Filestab.

Recod and auto process

Decode

Records satellites according to the settingRésoding Optionsunder the options

menu. Afterrecording, the audio is decoded and displayed using the settings
under theEnhancement®ptionsandProjectionmenus. Anumber of options can

be enabled to create a set of images, add frames to animations, create composite
images, and add images to web pages (8€efbr detailed information on creat-

ing web pages). These settings are also used bdutbeProcesscommand in the

File menu. Additionally the audio file and/or the map file (generated for map
overlays) may be remad ater processing is complete.

Starts the decode process. Decoding is automatically started after a file is opened or the direc-
tion or enhancement is changetihe automatic decoding may be disabled by sele®isg

able auto-decodein the Options menu. Manualstarting of the decode process isvals
required after anoptions under th®ptions menu hae keen changed, or when t&atellite

has been changed.

Partial Decode

Similar to Decodebut the cut start (he mary seconds into the file to start decoding) and cut
end (hev mary seconds into the file to stop decoding) may be specified. This is useful when a
recording contains signals fromdvor more satellites. It is also useful as a way to crop the
image, by decoding only the good portion of the image. When texiags are enabled, this

has an advantageve using theCrop command from thémage menu because texverlays

will be correctly positioned in the final image.

Auto Process

Builds and sees the images and adds frames to movies according fReberdsettings (under
theFile menu). Notehat this processing will not reme the audio nor map filessen if those
options are selected in the record settings.

View Image...

Allows viewing of imagesFiles in PNG, JPEG, BMP or PBM (PGM/PPM) format can be
viewed. Theimage transformations under th@age menu can be used to edit the images.
Enhancements and options are not applicable to these image3p@sdraw Imge instead).
Images can be gad using theSave Imge &...dialog under thd-ile menu. Inaddition, for
images produced by WXtolmg, the image may be geometrically transformed using the projec-
tions under thérojectionmenu.

View Movie...

Allows viewing of AVI animation.Under Wndows, Direct X version 8.0 or akle nust be
installed (note that for XP users Direct X will already be installed). Direct X can be obtained
from:

http://www.microsoft.com/directx

Under *NIX xanim must be installed to wethe AVI movies. Itcan be obtained from:
http://xanim.va.pubnix.com/home.html
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Update Web &e
Manually publishes (via FTP) the current web page. This does not add an image to the web
page. lItis useful whemutomatically FTP as imges are addedis not selected iWeb Page
SettingsunderRecordin theFile menu and is typically used to transfer the web page manually
over a dal-up Internet connection. It can also be used to update the web page after making
changes to the template.

Re-upload Web Ingges
Forces all images associated with the web page to be re-uploaded to the web site. Not required
in normal use, this can be useful when publishing tonaweb serer, or when all the images
on the website were accidently deleted.

Image Roperties...
Displays a windw showing information about the image being displayed.

Processing Info...
Displays a winde showing all the information which appeared on the bottom status line dur
ing the processing of the image.

Update Keplers
Uses the Internet to connect www.celestrak.com amchldad the latest orbital elements for
weather satellites. Orbital elements need to be updated regularly to userthg and pass
based recording options. Out-of-date keplers will cause tiistr&tion on werlays to be sig-
nificantly of. It is recommended that thepers be updated at least weekly verdays are
being used.For very accurate werlay placement, daily ornven twice daily updates are recom-
mended.

Pass List... Displays a list of satellite passes that are scheduled to be recorded from the current time until
the indicated time ahead (default 1 weekhe pass list displays only those satellites selected
in Active APT Satellitesnder theDptionsmenu. ltis also afiected by théRecoding Options

Clear Closes apimage being viewed and clears the displsgte that WXtolmg does not prompt to
save the image since the image can be re-generated from the origh\aE \OF raw image
later.

Stop When recording or decoding, this stops the recording or decoding process before it completes.

Exit,Quit  Terminates the program. On MacOS X, fQeit command can be found under ¥&tolmg
menu.

Direction Menu
This menu is @ailable only if expert mode is enabled (see Options -> GUI Optio@ejs the direction of
the pass for polar orbiting satellites. This setting is ignored when processingpWWiBRges. The setting
is also ignored if the map and projection supp@itt/{ Optionsunder theOptionsmenu) is enabled since
the program will determine the direction.

Autodetect Uses the last modification time of the input file to makgiess at which direction the
satellite was tneeling. Thisoption will fail to work correctly if the computers time zone
is not set correctlythe clock is dfsignificantly, or if the station is too near to one of the
poles. Alsathis requires that the timestamp on the file represents the time of the satellite
pass.

South->North  Northbound (ascending) pass. Satellite is moving from the south to the horthis
case the image is rotated 18@ues. Br combined NOAA APT images, the image is
subsequently shifted 1/2stwidth so that the channel A and B images remain on their
original sides of the combined image.

North->South  Southbound (descending) pass. Satellite is moving from the north to the south.

Satellite Menu
Selects the satellite to decoddnder normal circumstances, for polar orbiting satellites, this should be set
to Autodetect APT For geostationary satellites choose eitB&®ES Meteosator GMS Only in special
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circumstances (when regei control is not &ailable and multiple satellites areyashead and the wrong
satellite was recorded, or when decoding old audio files created by other programs with inaccurate dates or
times), should the specific satellite be selected. The specific satellite optionvsilatdeaonly if expert

mode is enabled (see Options -> GUI Options).

Autodetect APT
Autodetect is limited to checking for APT images from polar orbiting satellitéés speeds
up the detection process.

Meteosat Decodes WEFAX images from Meteosat geostationary satellites.

GOES Decodes WEFAX images from NOAA geostationary satellites (GOESMS Decodes
WEFAX images from GMS geostationary satellites.

Autodetect Autodetect attempts to determine the satellite using signal and image procd$smgption
is available only if expert mode is enabled (see Options -> GUI Options).

Autodetect WEFAX
Autodetect is limited to checking for WBK images from geostationary satellites. It is much
better to select the specific geostationary satellite (GOES, Meteosat), rather than use this
option. Thisoption is &ailable only if expert mode is enabled (see Options -> GUI Options).

NOAA Decodes APT images from M@ polar orbiting satellites (POES). This option igidable
only if expert mode is enabled (see Options -> GUI Options).

Meteor (series 3)
Decodes APT images from the Russian Meteor Series 3 satellltesoption is gailable only
if expert mode is enabled (see Options -> GUI Options).

Meteor (series 2)
Decodes APT images from the Russian Meteor Series 2 satéeliltesoption is gailable only
if expert mode is enabled (see Options -> GUI Options).

Resurs Decodes APT images from the Russian Resurs satellités.option is gailable only if expert
mode is enabled (see Options -> GUI Options).

Okean Decodes APT images from the Russian Okean sateliitieis. option is @ailable only if expert
mode is enabled (see Options -> GUI Options).

SICH Decodes APT images from the Russian SICH satellitéés option is gailable only if expert
mode is enabled (see Options -> GUI Options).

NOAA 12 Decodes APT images from M@ polar orbiting satellites (POES) and sets the seasairf
temperature calibration to NOAA 12. If tisea surface temgnhancement is not being used,
this option is equialent toNOAA This option is @ailable only if expert mode is enabled (see
Options -> GUI Options).

NOAA 14 Decodes APT images from M@ polar orbiting satellites (POES) and sets the seasairf
temperature calibration to M@ 14. If the Sea surface temgnhancement is not being used,
this option is equialent toNOAA This option is gailable only if expert mode is enabled (see
Options -> GUI Options).

NOAA 15 Decodes APT images from M@ polar orbiting satellites (POES) and sets the seasairf
temperature calibration to NOAA 15. If ti8ea surface temmgnhancement is not being used,
this option is equialent toNOAA This option is @ailable only if expert mode is enabled (see
Options -> GUI Options).

NOAA 16 Decodes APT images from M@ polar orbiting satellites (POES) and sets the seasairf
temperature calibration to M@ 16. If the Sea surface temgnhancement is not being used,
this option is equialent toNOAA This option is gailable only if expert mode is enabled (see
Options -> GUI Options).

NOAA 17 Decodes APT images from M@ polar orbiting satellites (POES) and sets the seaasairf
temperature calibration to NOAA 17. If tisea surface temgnhancement is not being used,
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this option is equialent toNOAA This option is @ailable only if expert mode is enabled (see
Options -> GUI Options).

NOAA 18 Decodes APT images from M@ polar orbiting satellites (POES) and sets the seasairf
temperature calibration to M@ 18. If the Sea surface temgnhancement is not being used,
this option is equialent toNOAA This option is gailable only if expert mode is enabled (see
Options -> GUI Options).

NOAA 19 Decodes APT images from M@ polar orbiting satellites (POES) and sets the seaasairf
temperature calibration to NOAA 19. If tisea surface temgnhancement is not being used,
this option is equialent toNOAA This option is @ailable only if expert mode is enabled (see
Options -> GUI Options).

Enhancements Menu
The Enhancementsmenu preides a wide range of enhancements. Changing the enhancement will auto-
matically start the decode process un@ssble auto-decodeés selected in th©ptions menu.

Normal Produce a normal image, using Gamma, Sharpening, Despeckling, etc settings.

Pristine Produce pristine output (best representation of original digital dagically used to
output images for further processing by other saferPristine images are unenhanced,
but unlike raw images hae been normalised to produce images which represent, as best
as the software is able to, the original digital data. No attempt is made to temperature
normalise IR imagesDisables gamma, sharpening, rotation, despeckling, and other
enhancements.

Contrast enhance
Contrast enhancement is performed as peCtmdrastsetting in theDptionsmenu.

Contrast enhance (NOAA A aly)
Contrast enhancement is performed only on the NOAA channel A image as @enthe
trastsetting in theDptionsmenu. Theother image is not shown.

Contrast enhance (NOAA®B mly)
Contrast enhancement is performed only on the NOAA channel B image as @enthe
trastsetting in theDptionsmenu. Theother image is not shown.

MCIR map colour IR (NOAA)
Colours the NOAA sensor 4 IR image using a map to colour the sea blue and land green.
High clouds appear white, M@r clouds gray or land/sea coloured, clouds generally
appear lighterbut distinguishing between land/sea anev ldoud may be dffcult.
Darker colours indicate warmer regions.

MSA Multispectral analysis (NOAA-# 2-4/1-4)
Multispectral analysisUses a NOAA channel 2-4 image and determines whigione
are most likely to be cloud, land, or sea based on an analysis of tharages. Pro-
duces a vivid false-coloured image as a result. There seeabeptions which déct
colouring of these images Image and Movie Options..under theOptionsmenu. This
enhancement does not use a palette nor is it temperature normalised.

MSA with precipitation (NOAA-# 2-4/1-4)
Same as MSA multispectral analysist high cold cloud tops are coloured the same as
the NO enhancement tovgi an goproximate indication of the probability and intensity
of precipitation.

MSA anaglyph false 3-D (NOAA-# 2-4/1-4)
Same as MSA multispectral analysigf breates a 3-D anaglyph image (must bevedk
with red/blue glasses). Operational only if the software has been upgraded.

HVCT false-colour (NOAA 2-4)
Similar to HVC (bel@v), but with blue water and with colours more indieatd land
temperatures.
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HVCT with precipitation (NOAA 2-4)
Same as HVCTdise-colourbut high cold cloud tops are coloured the same as the NO
enhancement to g an goproximate indication of the probability and intensity of precip-
itation.

HVC false-colour (NOAA 2-4)
Creates a false colour image from NOAA APT images based on temperature using the
HVC colour model. Uses the temperature wkgtifrom the sensor 4 image to select the
hue and the brightness from the visible (sensor 2) image (or the sensor 4 image if the
Use other sensooption is selected) to select the value and chroma. The HVC colour
model attempts to ensure thaffeiient colours at the same value will appear to the eye to
be the same brightness and the spacing between colours representing each degree will
appear to the eye to be simil@right areas are completely unsaturated in this model.

Sea surface temp (NOAA)
Creates a false colour image from A®APT images based on sea surface temperature.
Uses the sea surface temperaturevdeérirom just the sensor 4 image to colour the
image. Landappears black and cold high cloud will also appear bldtle sea suaice
temperature may be incorrect due to the presencevafidod, or of thin or small clouds
in the pixel @aluated, or from noise in the signal.

Thermal (NOAA) Produces a false colour image from AMDAPT images based on temperature.viRtes
a good way of visualising cloud temperatures.

Vegetation (NOAA 1-2)
Requires the rarelyvailable NOAA APT sensor 1 and 2 images (seen during the test
phase after satellite launch vegetative index is built up and this is used so that land
will be coloured green, water dark blue, and clouds wHite. palette is used for this
enhancement and the output is not temperature normalised.

Anaglyph false 3-D (GOES/NOAA)
Creates a false 3-D image (must bemdd with red/blue glasses) of the visible (sensor
2) image (or the sensor 4 image if no visible imagevélable) by estimating cloud
height. Operationadnly if the software has been upgraded.

Colour anaglyph false 3-D (NOAA)
Creates a false colour 3-D image based on the HVCT enhancement (mustvéeé vie
with red/blue glasses) using the visible aadlR images of the N@A satellite (or just
the farIR image if no visible image isvailable). Operationabnly if the software has
been upgraded.

Class enhancement (NOAA)
Unsupervised classification of NOAA APT images using an iteragtimisation clus-
tering algorithm.Uses an initial 27 cluster centres spaced equally along theitnen-
sional diagonal.The classification is used to tint the histogram equalised channel A
image.

NO colour IR enhancement (GOES/NOAA)
NOAA colour IR contrast enhancement option. Greatly increases contrast in tiee dark
land/sea regions and colours the cold cloud t@ggws fine detail in land and sea to be
seen and provides a very readable indication of cloud top temperafinissenhance-
ment option is temperature normalised.

ZA general IR enhancement (GOES/NOAA)
NOAA general purpose meteorological IR enhancement option. Increases contrast by
saturating the very W@ and very high temperaturegi®ns where there is typicallyewy
little information. This enhancement option is temperature normalised.
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MB thunderstorm (GOES/NOAA)
NOAA cold cloud top enhancement option. Useful forwimy where the strongest
rainfall is occurring in thunderstorms. This enhancement option is temperature nor
malised.

MD warm season MB (GOES/NOAA)
The NOAA MD enhancement is a modification of the popgeneral use MB enhance-
ment scheme. It is intended for warm season use, anélpsoimpreed enhancement
within the gray "step wedges" that depictdhm top" comection. An additional
improvement is better delineation of warmwiaclouds (30C to 7C). The middle cloud
range is somehat broader than the MB, and enhancement of details is minintbe.
erwise, it is the same as the MB enhancement. This enhancement option is temperature
normalised.

BD hurricane (GOES/NOAA)
NOAA hurricane enhancement option. Highlights certain temperatures in the eye and
eye wall of the storm system which are kmoto be related to the intensity of the hurri-
cane. Thienhancement option is temperature normalised.

CC enhancement (GOES/NOAA)
NOAA CC enhancement cuev Thisenhancement option is temperature normalised.
This option is wailable only if expert mode is enabled (see Options -> GUI Options).

EC enhancement (GOES/NOAA)
NOAA EC enhancement cugv Thisenhancement option is temperature normalised.
This option is wailable only if expert mode is enabled (see Options -> GUI Options).

HE western US (GOES/NOAA)
The NOAA HE enhancement is used principally by weather offices in the western
United States. It provides good enhancement of a wadiety of cloud types, but is
someavhat complex, and may be difficult to use at filstenhances l and middle leel
clouds common along the Pacific Coast of North America i ssparate gray shade
ranges. Thdreezing led is easily determined, an advantage fatiaéion users con-
cerned with icing. Step wedge regions displaycold infrared cloud top temperatures
associated with thunderstorms and frontal systems in 5 degree increments down to -60 C.
Two additional "repeat gray" geents define cloud top temperatures colder than -60C.
This enhancement option is temperature normalisgus option is wailable only if
expert mode is enabled (see Options -> GUI Options).

HF new western US (GOES/NOAA)
The NOAA HF enhancement is the most current of the "H" series of enhancements, and
is used principally by weather offices in the western United States. Midpsogood
enhancement of Yo and middle leel clouds common along theaBific Coast of North
America. Stepvedge regions displayewy cold infrared cloud top temperatures associ-
ated with thunderstorms and frontal systems in 5 degree incremantgaes0 C. Two
additional "repeat gray" genents define cloud top temperatures colder than -0
enhancement option is temperature normalisEtis option is ®ailable only if expert
mode is enabled (see Options -> GUI Options).

JF simple sea surface/cold cloud (GOES/NOAA)
The NOAA JF enhancement is a hybrid enhancement scheme used to highlight both sea
surface temperatures, and cold cloud tops associated with thunderstorms and other
weather systems. It is someat simpler to interpret than the later JJ enhancenidre.
coldest portion of the enhancement (less than -33C) is nearly identical to the general-use
MB enhancement. Maximum enhancement is provided at #mnwend (25 to 10C) to
depict sea surface temperatures amadmvliov clouds in tropical and sub-tropical areas.
This enhancement option is temperature normalisgus option is wailable only if
expert mode is enabled (see Options -> GUI Options).
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JJ sea surface/cold cloud (GOES/NOAA)

The NOAA JJ enhancement is used to highlight both sea surface temperatures, and cold
cloud tops associated with thunderstorms and other weather syst®Blagimum
enhancement is provided at the warm end (23 to OC) to depict sea surface temperatures
and lav clouds. Thepresence of a freezingvig break point is important forvéation

users interested in icing conditions. Multiple, steep, ramp enhancement rangds pro
considerable detail within cold cloud tops such as thunderstorms, but ificslltifo
determine the actual temperatures witly accurag. This enhancement option is tem-
perature normalised. This option ig#able only if expert mode is enabled (see Options

-> GUI Options).

LC fog/low cloud/precip (GOES)

The NOAA LC cunre is used on images from the 3.9 micron shenteinfrared channel

(CH2) of GOES. It provides maximum enhancement in the temperature range where fog
and law clouds typically occur (36C to -9C). Another enhanced thermal range is from
-10C to -29C, the gion of precipitation generation in mid-latitude weather systems.
Since CH2 is sensitt 1 "hot spots,” a steep,w&se ramp is found at theanm end

(68C to 50C) to she any dosenable fires as white. There is no enhancement atehe v

cold end (-30 to -67C), due to the instrument noise normally present at these tempera-
tures. Thisenhancement option is temperature normalised. This optiaailatde only

if expert mode is enabled (see Options -> GUI Options).

TA enhancement (GOES/NOAA)

NOAA TA enhancement cue: Thisenhancement option is temperature normalised.
This option is wailable only if expert mode is enabled (see Options -> GUI Options).

WV water vapour (GOES)

Options Menu

The modified NOAA WV cure is wsed for the 6.7 micron water vapor channel (CH3) on
GOES. Theonly temperature range that is enhanced is between -5C and Té@per-
atures colder than -90C are shown as white, and temperatanegmthan -5C are dis-
played as black.This enhancement option is temperature normalised. This option is
available only if expert mode is enabled (see Options -> GUI Options).

Selects a variety of options. The factory default settings for all thefapiéns in this menu is &f For
Gamma, Sharpen, Despeckle, dtre factory default setting is indicated by an asterisk; a plus indicates an
alternatve ecommended setting.

Disable auto-decode

If selected, this option pvents WXtolmg from starting an automatic decode when¢he
enhancement or direction is changed.

Interpolate If selected, enables interpolate andrsample (50% layer images). Creates larger images by

increasing the sampling rate in the horizontal and interpolation inettieal. Inthe case of
NOAA images the Channel B image is also shifted down to compensate for the satellite
movement and the sampling method. This provides bettgstration between the images and
thus imprees image quality in multispectral transformations. This optiorvalable only if

expert mode is enabled (see Options -> GUI Options).

Use other sensor

The HVC and HVCT enahancements normally require one of the channels to be a visible light
sensor By setting this option, the enhancement will realse of the &r-IR sensor when no
visible sensor iswailable.

Disable PLL
If selected, disables the phase locked loop code used to ensure the image is not bent due to
dopplershift nor slanted due to slight variations in sampling rate. This option is sometimes
useful with recordings from scanners to disable the burst PLL on Meteor and Resurs satellites
which can cause problems when decoding very poor quality signals.
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If selected, disables the normal cropping of noisy/smgnal portions of the image. See also
Crop telemetrywhich crops the sides of the image.

Crop telemetry

Resync

If selected, crops the telemetry lines from the sides of the infage.als@Ghow Allwhich dis-
ables the automatic cropping of the top and bottom of the image.

If selected, enables attempts to resync image. If en&ddimgattempts to correct for stair
stepped/split images caused by missing time in the input audio fikevérowith low S/N
ratios or from recordings made by too narrt- bandwidth receiers (scanners), this may
cause false corrections to be made resulting in very broken images.

Disable Map Overlay

If selected, disables theveslaying of maps on the imageOverlaying maps requires the
keplers to be up-to-dateSeeUpdate keplersin the File menu. Disablingnap werlays does
not disable map generation. Seeable map and projection suppdmtGUI Options

Noise filter If selected, enables the noise filtdhis is a 5x5 median edge-preserving image fil@auses

Contrast

significant blurring of the image. This option ig#able only if expert mode is enabled (see
Options -> GUI Options).

Allows selection of the contrast enhancement used within the HVC, HMGA, and eg
enhancements. Operatiorally if the software has been upgrad&klect eitheHist Eqfor
histogram equalisatior,inear (constantfor a constant linear enhancement whiehies only
according to the satellite senstmear (variable)for variable linear enhancement which is
adjusted for eery image, oiNoneto disable ay contrast enhancement. If images are going to
be later compared or combined than eithierear (constant)or Noneshould be used as all
images are treated in exactly the same way with these options.

lllumination Compensation

Gamma

Sharpen
Despeckle

lllumination compensation corrects for the werelighting of the eartls aurface by the sun.
Full compensation corrects each image so that the ®antface appears to be lit from directly
overhead. HighMed and Lev compensation apply some compensation, but do not fully cor
rect. Noneperforms no compensation. Note that wittv Isun angles compensation can dra-
matically increase the effects of noise in the signal.

The default gamma correction to applypically between 1.00 and 2.5@ value of 1.00 dis-

ables gamma correctiorf-or PC dsplays a gamma of about 1.40 seems to be optimal for
viewing, for Macintosh systems 1.15, for SGI systems 1.10, for NeXT systems 1.00, and for
Sun and other systems 1.40 is recommended.

Set sharpening factoirhe default is 0.6.

Enables removing of random noise in the image.xffeet mode is enabled (see Options ->
GUI Options), then the despeckling threshold may be Betdsable despeckling usgone

The threshold is the number of standardiatéoons the pixel in question can vary from the
mean of the other pets in a 5x5 area surrounding it before it is considered noise and is
replaced by the mearale. Increasingigma decreases the number of pixels which will be
replaced, decreasing sigma increases the number of pixels which will be replaced.alilie def
is none, a \alue of 2.0 is recommended in most circumstances (this is the value used if
despeckle is enabled in norpert mode).Lower values will cause significant blurring of the
image.

Active APT Satellites

Allows selection of the aeg APT satellites.The Actve APT Satellites dialog controls which
satellites maps may be created for and which satellites will be recordedRietioel only
when active APT satellites eaoverheadoption is checked in thRecoding Optionsdialog.
Also allows setting of the satellite frequgrn®Hz) used when control of the reeei's chan-
nel is enabled A priority can also be set. When dvor more satellites areverhead then the
satellite with the highest priority (1=highest, Sakst) will be recorded. If the satellitesviea
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the same prioritythen the satellite with the highest maximumvatien will be recorded.Pri-
ority has no déct if recever control is not enabled in thRecoding Options If Update this
table when updating éplersis selected, then the software will select thevactatellites and
set their frequencies (priorities will not be changed) according to the currently satéllites
(downloaded via the InternetfEnablingExpert modeén GUI Optionsallows no longer trans-
mitting satellites to be selected.

Ground Station Location
Allows setting of the ground station locatiobatitude and longitude should be entered in
degrees and fractions of gees and not in degrees, minutes, and seconds (north and east
should be entered as pogitirumbers, south and west should be entered gaive rumbers).
If you enter the name of a large city (population 100,000 or more) and the country (e.g. United
States, United Kingdom), you can set the latitude and longitude automatically by clicking the
Lookup Lat/Lorbutton. Thismust be set if mapwverlays are being used or if tiiecod only
when active APT satellites eaoverheadoption is chec&d in theRecoding Optionsdialog.
Alternatively, you can check thblse GPSo0x, and set the serial port the GPS is connected to.
You must also set the baud rate (use 4800 if unsude).your GPS you will hae o enable
NMEA output (at the same baud rate) as this will not be enabled buylde€Checkthe GPS
manual for instructions on Woto do his. TheGPS must support NMEA 2.x. While this
option is enabled, WXtolmg will check the GPS for position information when neéldesl.
GPS option is ailable only on upgraded copies. The GPS requires GGA, RMC or GLL
NMEA sentances to be output by the GPS. Setting time is eallalle if an RMC or GLL
sentance iswailable. You can also keep the PC clock set using the GPS by checkisgtthe
PC clok from GPSbox. Notethat WXtolmg uses WGS84 datum for position, projections,
and map werlays. OnLinux and Mac OS X you'll hee o run the commanéusr/sbin/visudo
as root and add a line to the bottom similamtgusername myhostnameNOPASSWD:
/bin/date Where myusername is your user name and myhostname is the cosimgerame
(runhostnaméo get the hostname if unsure).

Internet Options...
WXtolmg requires up-to-date Keplers taild map oerlays and predict satellite passeu
can choose to obtain the Keplers from Celestrak or Spad. TCelestralonly has a tempo-
rary permit to distribute Keplers, so it is highly recommended that a username andrgassw
from Space Track is obtained from:
http://www.space-track.org/

Once you recee your password, you will need to login to the Spaeck website and change
your temporary password, then sel€gtt Keplers rom S$ace Tack and enter your username
and password.

On Windows XP and Whdows Server 2003, you can configure the Internet time server set-
tings. Enablinghis will ensure maps are aligned accurately.

Recording Options...
Used to select the recording mode and options.

Recod using WEFAX start/stop tones (for geostationary satellites on 1.6GHz)
If selected then recording starts when the WKIStart signal from a geostation-
ary satellite (i.e. GOES, Meteosat, or GMS) is hd@ecording stops when the
WEFAX stop signal is heard.

Recod only when active APT satelliteseaoverhead
If selected, then recording occurs only when a satellite is passirgead which
is selected in théActive APT Satellitedialog in theOptionsmenu and also meets
the conditions bele. This is the defult. Thisrecording mode is the mostfief
cient and uses the least CPU since it does not need to continuously decode the
audio signal.
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with maximum elevation above (degrees)

Only satellites where the maximum aton (abae the horizon) is equal to or
better that the value here will be recorded. The factory default is 20.

record only when satellite is above (degrees)

and require

soundcard

sample bits

antenna type
receiver type

receiver port

receiver baud

Waits until the satellite is alve the horizon by this number of giees before
recording and stops recording when the satellite fallswbdlds number of
degrees. Théactory default is 8.

Allows an optional additional check before recording is staredquelt break

is selected then the progranaitg for the volume to rise ab® the sound trigyer

level before recording.If 2400Hz carrieris selected then then the programite

for a 2400 Hz carrier to be detected before recording starts. If either of these
options is selected then tfiaish recoding delayis also used, ut recording will

stop earlier if the satelliteafis belav the value set imecord only when satellite is
above If nothingis selected, then the program will record while the satellite is
overhead whether a signal is detected or not. The factory defa2d0i3Hz car

rier.

Allows selection which soundcard should be used for recordefault on Linux
is "/dev/dsp" (additional soundcards are named "/dev/dspl", "/dev/dsp2", @tt.).
DOS and Vihdows the default is the first soundcar®n the Mac, the default is
the Macs default soundcard.

Allows selection of 8 or 16 bit recording46-bit recordings produce the best
quality images, bt 8-bit recordings reduce the size of the recordings by A&lf.
bit recordings are highly recommendeilhe factory default is 16. This option
can only be changed if expert mode is enabled (see Options -> GUI Options).

Antenna type.

Setting for computer control of rewei channel. Seto noneif the recever does

not support computer control or is not connected to the compGtattrol only
occurs if the recording mode is setRecod only when active APT satellitesear
overhead If using PCR1000, enseiou have set the PCR1080hternal jumper

for line out as discussed in the PCR1000 manual bafing this contl. Alter-
natively you may use the PCR100 setting for the PCR1000 which assumes
speaker-leel output. ThePCR1500 setting disables the speaker and assumes the
soundcard is set to pickup input from the PCR USB Audiwid®e Kenwood
recever control operates at 4800 baud aef. AR3000,AR5000, and AR
recever control operates at 4800 baud agf. BC245X[T, BC895XLT and
BC780XLT recever control operates at 9600 baud aigf. ThePSR-500 is sup-
ported only on Whdows and you should set "DG INT PRIME" to 1 to et
dropouts during reception. IC-R8500 and IC-R10 use 9600 baud default and
addresses 4A and 52 respedti. Use External to run the external command
wxctl (wxctl, wxctl.com, wxctl.&e, or wxctl.bat) for control (passed the satellite
name as argument 1, the frequemtMHz as agument 2, and the reser port as
argument 3; satellite name will be an empty string and frequernit be 0.00
when no channel is selected -- generally the control program should enter scan
mode but this is optional).

The RS-232 port used for computer control of the vecehannel. Ifthe control
is not via RS-232 (e.g. the game port) this setting is ignored.

Sets the baud rate to communicate with the vecelf the receier baud rate can-
not be changed, this setting willvearp efect. Usereceiver defaulto select the
default baud rate for the regei.
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Auto Processing Options...
Used to select the options for automatic generation of images, composite images, (aru-
mations), and web page creatioBeeRecordunder theFile menu (which contains the same
options) for details.

Map Overlay Options...
Allows selection of which features and what colours they appear on the map overlays.

Text Options...

Allows text to be displayed on the image. Operational only if the software has been
upgraded. There are two text areas. To enable either or both select the associated
Enable box. The text may contain percent sequences that will be expanded as
described in Filename Template below. The colour may selected from the list and the
default size (in points) selected from the list. The position on the image may be speci-
fied using X: and Y:. The value may be ¢ for centre, or a positive number for the num-
ber of pixels from the left or top edge, or a negative number for the number of pixels
from the right or bottom edge. The text box can contain multiple lines. A line can
start with fontsize=##, to set a different font size (in points) for the line and any subse-
quent lines. The TrueType Font allows the selection of an alternative true type font.
Leave this blank to use the supplied font. An alternative font can be used to provide
text overlays for European and Asian languages as the built-in font supports only the
standard ASCII (English) characters.

Projection Options...
Allows for the control of projections. Operational only if the software has been
upgraded.

Reference Latitude
The map projection will be centered at this latitude. Use negative numbers
for south, positive for north. Note that this is not the centre of the image
but the centre of the projection itself (if in doubt leave this field blank).

Reference Longitude
The map projection will be centered at this longitude. Use negative num-
bers for west, positive for east. Note that this is not the centre of the image
but the centre of the projection itself (if in doubt leave this field blank).

North Boundary (latitude)

South Boundary (latitude)
If the boundaries are specified then the resulting image will will be cut off
at these boundaries and will not show points outside. Will not function
unless all four boundaries are given. Use negative numbers for southern
hemisphere. Should be between 90.0 and -90.0.

West Boundary (longitude)

East Boundary (longitude)
If the boundaries are specified then the resulting image will will be cut off
at these boundaries and will not show points outside. Will not function
unless all four boundaries are given. Use negative numbers for west, posi-
tive for east. Should be between -180.0 and 180.0.

Scale (norm 1.0) or output width
Sets the scale or output width for the projection. Scale is a relative value
which defaults to 1.0. A value of 0.5 will result in an image half the width
and half the height. A value of 2.0 will result in an image twice as wide
and twice as high. There is no best value, but large or small values may
result in a loss of image quality. Values greater than 50 are assumed to be
the required output width in pixels (rather than a relative scale). Values of
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scale greater than 2.0 are not supported, and values for output width less
than 50 are not supported.

This option is available only if expert mode is enabled (see Options -> GUI Options).
Sampling rates can be much more easily and accurately set using Slant Correction in
the Image menu. Allows manual setting of the sample rate. Try varying the sample
rate from the normal by 5 samples per second at a time (so if you have 11025 samples
per second audio files try, 11020, 11030, 11015, 11035, 11010, 11040, etc) until the image
is reasonably vertical, then adjust by 1 or 2 samples per second until the PLL locks
and the image becomes exactly vertical. Determination of the sound cards sample
rate normally needs to be done only once. A setting of 0.0 indicates that the default
sample rate should be used.

Image and Movie Options...
Used to set a variety of options relating to image and AVI output.

Default Image Format

Set the default image format to one of JPEG, PNG, BMP, PBM
(PGM/PPM/PNM), or AVI. This is used when auto saving images. Nor-
mally, WXtolmg uses the filename extension (one of .png, .bmp, .pbm,
.pgm, .ppm, .pnm, jpg, .jpeg, or .avi in lower or upper case) to determine
the output file type, when the Save Image as... item from the File menu is
selected. If the output file extension is not specified or the output exten-
sion does not indicate a known format, then the default image format is
used to set the file type.

Default for Anaglyphs

Set the default image format for anaglyphs to one of JPEG, PNG, BMP,
PBM (PGM/PPM/PNM). This is used when auto saving images. Note
that anaglyphs are best saved in a lossless image format (PNG, BMP, or
PPM) as the colour shifts caused by JPEG encoding can affect 3-D viewing.

Default for Composites

JPEG Quality

HVC Palette

Thermal Palette

Set the default image format for composite images to one of JPEG, PNG,
BMP, PBM (PGM/PPM/PNM). This is used when auto saving images.
Note that composite images are best saved in a lossless image format
(PNG, BMP, or PPM) because multiple overlaying of the composite image
can compound the loss of image quality inherent in JPEG images.

Sets the quality for JPEG images. The factory default is 65. The valid
range is 0 to 100. See Image Output Formats for discussion.

Allows selection of the palette for the HVC enhancement. PNG, BMP and
PPM format files are supported. See the -P option in the wxtoimg com-
mand line manual for the technical details. If left blank, then the default
HVC palette is used.

Allows selection of the palette for the Thermal enhancement. PNG, BMP
and PPM format files are supported. See the -P option in the wxtoimg
command line manual for the technical details. If left blank, then the
default Thermal palette is used.

Sea Surface Temp Palette

Allows selection of the palette for the Sea Surface Temperature enhance-
ment. PNG, BMP and PPM format files are supported. See the -P option
in the wxtoimg command line manual for the technical details. If left
blank, then the default Sea Surface Temp Palette is used.
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MSA Sea to Land
It is highly recommended that you do not change this option. Multispec-
tral analysis sea to land adjustment. The factory default value is 50. This
should be decreased if land in multispectral analysis enhancements
appears blue, and increased if water appears green. The valid range is 0 to
100. This option is available only if expert mode is enabled (see Options ->
GUI Options) and should really never be changed.

MSA Land to Cloud
It is highly recommended that you do not change this option. Multispec-
tral analysis land to cloud adjustment. The factory default value is 50.
This should be decreased if cloud in multispectral analysis enhancements
appears green and increased if land appears gray or white. The valid
range is 0 to 100. This option is available only if expert mode is enabled
(see Options -> GUI Options) and should really never be changed.

AVI Codec The compression method to use for AVI animations. Currently three types
are supported: MJPG, JPEG, and RGB. MJPG (Motion JPEG) provides for
excellent compression, JPEG provides somewhat less compression (and
may be less standardised), RGB does no compression at all. Under BeOS
JPEG is recommended (as there are no available MJPG decoders), under all
other operating systems MJPG is the recommended choice (MJPG
decoders for Windows are available in the DirectX package). The JPGQ
and /JPGS codecs are provided for backward compatibility and will be
dropped in a future release.

AVI Transparency
Enables transparency on AVI images so that if the pixels in the current
frame are not set the pixels from the previous frame will be used. Better
results may be achieved by increasing the AVI Quality or using the RGB
AVI Codec. The factory default is enabled.

AVI Quality Sets the quality for AVI animations. The factory default is 20. The valid
range is 0 to 100. See Image Output Formats for discussion.

AVI Max Frames
The maximum number of frames in the animation. If, after adding the
new image, the number of frames in the animation exceeds this number
then frames will be dropped from the beginning so that the total number
of frames is AVI Max Frames.

AVI Frame Rate The rate at which to display the animation in frames/second. Normally
values between 0.2 (1 frame every 5 seconds) and 8.0 (8 frames per second)
are useful. The factory default is 1.0.

AVI Scale Reduce output animations by fact factor. Factor should be between 0.0 and
1.0. The factory default is 0.5.

File Names and Locations...
Sets the locations for opening and saving files.

Audio file naming
Audio file names are the time of the recording. You can change audio file
name format to some other time format. Beware that this setting also
affects how WXtolmg determines when a file was recorded. Selecting
Other will prevent WXtolmg from using the filename to determine the time
of recording (and audio files will be recorded as MMDDHHMM UTC time.
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Filename Template
Used to define the default output filename, and the filename for raw files
used when recording. If left blank, then this defaults to the input filename
or when recording to %T. See Filename Template section for details.

Use for audio recordings/maps too
If selected, the audio recordings and any overlay maps will be renamed to
match the template after decoding. Note that if a no decode option is
selected when recording then the audio recordings/maps will not be
renamed to use the the template.

Audio File Location
The folder/directory in which audio files will be saved when record-
ing/decoding. Also the default location when opening audio files.

Raw Image Location
The folder/directory in which raw images will be saved when recording.
Also the default location when opening/saving raw images.

Save Image Location
The default location when saving processed/enhanced images using the
Save Image as... option under the File menu.

Map File Location
The folder/directory in which map files will be saved when record-
ing/decoding.

Thumbnail Location
The folder/directory in which thumbnail images will be saved.

GUI Options...
Allows setting of operations that affect the graphical user interface (GUI).

Temperature units
When temperature is shown, this indicates what units should be used.
Degrees Celsius, Fahrenheit, or Kelvin may be chosen. The factory default
is Celsius.

Distance units ~ Allows the selection of miles (mi), nautical miles (nm), or kilimoters (km)
where WXtolmg shows distances. The factory default is km.

Help Language  Select EN (English), ES (Spanish), DE (German), JA (Japanese), or PL (Pol-
ish) for the help language. Translations for most languages are not yet
available. If you can help in translation for any of these or other languages
contact us at http:/ /www.wxtoimg.com/email.html .

Help Font Size  Allows the font size for help text to be made larger or smaller. +0 is the
default size, negative numbers use smaller than normal fonts, positive
numbers larger than normal fonts.

Date/time format Allows selection of the date and time format where WXtolmg displays
dates and times. Operational only if the software has been upgraded.

Show time as UTC
If enabled times will be shown in UTC, if disabled, local time will be
shown. Operational only if the software has been upgraded.

Enable map and projection support
By default this is enabled, but on very slow processors disabling this can
speed up image generation by disabling support for map overlays, projec-
tions, good quality MSA (multi spectral analysis enhancements), MCIR
enhancements, and illumination compensation. Because of the significant
impact on the use of MSA and MCIR enhancements and on other
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WXtolmg features, it is strongly recommended that this feature be left
enabled. This option is available only if expert mode is enabled (see
Options -> GUI Options).

Flip Meteor series 3 images

If selected then images from Meteor series 3 will be automatically flipped.
This is useful if map and projection support is disabled and Meteor 3 is in
a phase where all the images are being presented upside down. The fac-
tory default is off. This option is available only if expert mode is enabled
(see Options -> GUI Options) and is of little use since the failure of Meteor
3-21.

Use private colormap

Tear off menus

If the display has only 256 Colors (8 bit), then when this is selected (the
factory default) a new colormap will be installed. This provides for the full
256 colours to be used by WXtolmyg itself (instead of being shared with all
other applications and the operating system). This setting should have no
effect on High Color (15 or 16 bit) or True Color (24 or 32 bit) adapters.
The options must be saved and the program exited and restarted before
any change will take effect. This option is available only if expert mode is
enabled (see Options -> GUI Options).

If enabled, then next time program is started menus can be torn from the
application (by selecting the dashed line at the top of the menu). This will
place the menu in a separate window which can be moved around the
screen. This allows for easier selection of enhancements and options.
Operational on Windows and Linux platforms only and only if the soft-
ware has been upgraded.

Status info text size

Allows you to change the size of the text on the status lines at the bottom
of the main window and the info line above the main image. The default
is Normal. This options is only available on Windows platforms.

Automatically enter record mode

If selected then when WXtolmg will automatically enter record mode as
though Record had been selected from the File menu and Record had been
clicked. For APT satellites, record mode is entered a few minutes before
the next satellite pass and exited after processing is complete. This mode
is also useful to automate recording/decoding when WXtolmg is started
automatically. Operational only if the software has been upgraded.

Disable sat position during record

Disables satellite position (elevation and azimuth) calculations and display
while recording a satellite passing overhead. This may be useful on slow
computers to help prevent breaks in the image caused by missing time in
the recording.

Automatically update Keplers

If selected, then Keplers will be downloaded via the Internet approxi-
mately every 24 hours. Requires an "always-on", or automatic connection
to the Internet. Operational only if the software has been upgraded and if
WXtolmg is being used to record.

Auto-save options on exit

If selected then all options will be saved as if Save Options had be chosen
just prior to exiting the program. The factory default is on.
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Maximum number of thumbnails
Sets the maximum number of thumbnails that can be displayed on any of
the thumbnail pages. The most recent thumbnails are shown.

Enable Expert Mode
Enabled a set of mostly historical features, many of which have little use.
Options must be saved and the program exited and restarted before
changes take effect.

Save Options
This saves all the options on the options menu (and options dialogs on the options
menu) and with the exception of Interpolate, Show All, Resync, and Disable PLL.
This option also saves the window size and position. Also the recording modes and
image and movie settings are saved. If this menu item is not chosen, then any
changes made will not be restored when the program is restarted (unless Auto-save
options on exit is selected in the GUI Options dialog).

Projection Menu
The Projection menu supports changing the map projection used to display the APT satellite
image. The default normal projection is the unaltered space oblique projection the satellite pro-
vides.

Normal ~ The unaltered space oblique projection that the satellite provides.

Mercator  The classic Mercator projection. Lines of constant direction (thumb lines) appear
straight. This cylindrical projection does not work at or near the poles, and displays
considerable area distortion away from the equator.

Equidistant Cylindrical
An equidistant cylindrical projection where the lines of latitude and longitude are par-
allel and equally spaced. Sometimes called Plate Carree. Displays considerable area
distortion near the poles.

Equal-Area Cylindrical
An cylindrical projection where land masses of equal area have the same area. Dis-
plays considerable shape distortion near the poles.

Eckert IV An equal-area projection with semi-circle meridians used for world maps.
Eckert VI ~ An equal-area projection with sinusoidal meridians used for world maps.
Mollweide Another equal-area projection commonly used for world maps.

Miller A compromise cylindrical projection which shows less distortion than the Mercator
but does not show straight rhumb lines.

Polar Lambert Equal-Area
The Polar Lambert Azimuthal Equal-Area projection. An azimuthal projection similar
to the Polar Stereographic but which is equal area.

Polar Stereographic
An azimuthal projection where the lines of longitude converge at the poles.

Polar Azimuthal Equidistant

An equidistant projection centered at the poles.
Orthographic

A perspective projection from infinite distance.

Image Menu
Options which use the image or allow the image to be hand altered after processing.

Slant Correction...
After selection, a line may be dragged along a vertical edge to set the sampling rate.
See the Required Calibration... document under the Help menu for more details.
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Move Map Overlay...
After selection a line may be dragged between a point on the overlay and the corre-
sponding point on the image to adjust the position of the overlay.

Colour Negative
Creates a colour negative of the image. For grayscale images, black becomes white
and white black.

Warmer Colours
Warms the colours in the image by shifting the image toward the red end of the spec-
trum. The effects can be quite subtle, so the command may have to be repeated before
the effect becomes noticeable.

Colder Colours
Cools the colours in the image by shifting the image to-wards the blue end of the spec-
trum. The effects can be quite subtle, so the command may have to be repeated before
the effect becomes noticeable.

Conwvert to Grayscale
Converts the image to a grayscale image.

Histogram Equalise Image
The image is histogram equalised. Note that this operation operates on the entire 8-bit
displayed image and so is inferior to using the histogram equalisation under enhance-
ments (which operates in 16-bits). However, it is quite useful for histogram equalising
cropped or magnified images.

Increase Contrast
Increases contrast in the image. Use multiple times to increase contrast more.

Flip Image Rotates the image 180 degrees.

White Background...
Sets the background on an image which has been geometrically transformed (i.e. the
Projection was set to something other than Normal), from black to white. This option
does not work on JPEG images viewed using View Image. See also White background on
projections in Image Settings under Record in the File menu for setting the background
to white for automatically saved images.

Shift Image...
After selection, a point on the displayed image may be selected which will be set as
the new left edge.

Crop Image...
After selection, by clicking and dragging a box, the region to be cropped may be
selected. Then clicking inside the box will crop the image; clicking outside the box
will cancel the operation.

Rotate Image...
Allows the image to be rotated. After selection, drag a line from left to right. This line
will become horizontal in the rotated image.

Resize Image...
A sub-menu allows selection of the new size (as a percent of the original). The image
can only be reduced in size. The image can be reduced several times to create very
small images.

Magnify Area...
A sub-menu allows selection of the degree of magnification (as a percent of the origi-
nal). After selection, by clicking and dragging a box, the region to be magnified may
be selected. Then clicking inside the box will cause that part of the image to be magni-
fied; clicking outside the box will cancel the operation. Magnification uses
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interpolation to minimise pixelation.

View Enhancement Curve
Shows the current enhancement curve or palette for the selected enhancement in the
Enhancements menu. If the enhancement is a histogram equalisation enhancement,
then the histogram equalisation for the current image will be shown.

Undo All (Decode)
Does a decode, which has the effect of undoing all shift and crop operations.

Filename Template
The filename template specifies the output filename format. This can be found in File Names and
Locations... under the Options menu. If the filename template is left blank it defaults to the orig-
inal pathname. The % sequences in the filename template are replaced as defined below. All
replacements will be converted to lowercase.

For example an Filename Template of:
Y%os-%T-%e

Could produce output filenames like:
meteor3-01061123-norm.jpg
noaa-12-01062348-msa.bmp
noaa-01062352-mcir-precip.png
noaa-01062350-raw.png
met7-01022603-norm.png

Templates may expand to create directories, for example:
°/oY/°/om/°/od/°/os-%e
%Y\ %m\ %d \ Y%s-%e

under Linux/*NIX/MacOS X and Windows/DOS respectively.

%@ causes any time or date % sequences (either before or after the %@) to use local time
rather than UTC time.

%s is replaced with the satellite name in lower case (up to 8 characters, e.g. met7, noaa-14,
meteor3).

%N is replaced with the satellite name in mixed case and with spaces (e.g. MET7, NOAA
17, Meteor 3-5).

%g is replaced with the satellite type in lowercase (e.g. met, noaa, meteor3).

%D is replaced with the satellite direction, either northbound or southbound.

%p is replaced with a single character abbreviation for the satellite direction, either N for
northbound or S for southbound southbound.

%E is replaced with the maximum elevation for the pass in degrees (0-90).

%" is replaced with the azimuth at maximum elevation for the pass in degrees (0-360).

%z is replaced with a single letter, either E or W to specify the azimuth is more easterly or

more westerly at maximum elevation.

Yo: is replaced with either east or west to specify the azimuth is more easterly or more
westerly at maximum elevation.

%£ is replaced with the original audio input filename but without any folder or directory
name nor with any extension (e.g. if the input filename is /tmp/03042215.wav then
%f is replaced with 03042215).

%F is replaced with the format (either apt or wefax).

%C is replaced with the WEFAX spectral band or NOAA APT channel a-channel b. Up to
3 characters, e.g. WEFAX: vis, ir, nir, NOAA APT: 2-4, 3-4. If unknown will be
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replaced with nothing.

%e is replaced by the name of the enhancement (e.g. za, hvc) or raw for raw, pris for pris-
tine, norm for normal (no enhancement). With the histeq and norm enhancements, if
only the A or B channel is selected then the name of the enhancement is appended
with a or b (e.g. histegb, contrasta, norma).

%1 is replaced by the sector. Up to 4 character sector information from WEFAX digital
headers. If not available (or APT), will be substituted with nothing.

%8,9,10,11%
is replaced by the 9th, 10th, 11th and 12th characters from the WEFAX digital header
(they appear off by one because numbering starts at 0). The valid range of the num-
bers is 0 - 49 which corresponds to the 50 characters in the digital header. The num-
bers start at 0, are separated by commas, and a % ends the sequence. If the character
selected is a space (or is otherwise not available) then nothing will be substituted (i.e.
the resulting filename will not contain space characters).

Yr is replaced by the satellite radio frequency in MHz (e.g. 137.50).

%k is replaced by the date in YYMMDD format. For WEFAX this is the date embedded in
the digital header from the image. For APT the current UTC date is used. (Equivalent
to 0/oyo/ol‘l‘lo/od).

%K is the same as %k but in DDMMYY format (equivalent to %d%m%y).

%L is the same as %k but in MMDDYY format (equivalent to %m%d%y).

%d is replaced by the 2 digit day of the month (01-31).

%m is replaced by the 2 digit month (01-12).

%y is replaced by the year without the century (e.g. 01).

%Y is replaced by the year with the century (e.g. 2001).

%T is replaced by the date and time in MMDDHHMM format. For WEFAX this is the
date and time embedded in the digital header from the image. For APT the current
UTC time is used. (Equivalent to %m%d%H%M).

%t is replaced by the time in HHMM format. For WEFAX this is the time embedded in
the digital header from the image. For APT the current UTC time is used. (Equivalent
to %H%M).

%H is replaced by the 2 digit hour (24-hour clock) (00-23).

%I is replaced by the 2 digit hour (12-hour clock) (0-12).

Yo= on MTSAT or GMS images is replaced by the 2 digit hour (24-hour UTC) given in the
digital header. For other satellites, this will be the same as %H.

%P is replaced by the AM/PM designation.

%M is replaced by the 2 digit minute (00-59).

%Z is replaced by the timezone name or abbreviation.

%% is replaced by %.

Image Output Formats
Images may be produced in JPEG, PNG, BMP, PBM (PGM/PPM/PNM), or AVI format.

The output format: JPEG (jpg), PNG (.png), BMP (.bmp), PNM (.pnm), or AVI (.avi) used for out-
put is specified by the filename extension. If you do not use an extension, or the extension does
not relate to one of the supported output formats, the default will be the format set in the Image
and Movie Options... under the Options menu.

JPEG files are a lossy compressed format. The quality (Image and Movie Options under the Options
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menu) can be varied to control the amount of detail preserved and the amount of compression.
Quality can vary from 0 to 100. The useful range is probably 30 to 95 where a quality of 30 pro-
duces a well compressed image (although lacking in much detail and with some significant arti-
facts), whereas a quality of 95 produces a very good image, but with little compression. JPEG
cannot support 16 bit grayscale images. JPEG images can contain comments.

PNG files are a compressed lossless image format. Due to having good compression and being
lossless they are the preferred format. PNG supports 16 bit grayscale images, comments, and
records gamma.

BMP files are an image format widely used on PC based systems. The BMP files produced by
WXtolmg are not compressed. BMP files cannot support 16 bit grayscale images, nor can they
contain comments.

PBM files are an uncompressed image format but well suited to further processing and display
on *NIX systems. PBM (bitmap) files are also called PPM (colour), PGM (grayscale), and PNM
(any). They support 16 bit grayscale images and comments.

AVI files are animated sequences of images. AVI files support different types of compression,
RGB which is uncompressed, JPEG which uses JPEG compression, and MJPG (or Motion JPEG)
which uses a special abbreviated form of JPEG compression. The type of compression used in the
AVI file is controlled with the configuration file parameter AVI Codec. For JPEG and MJPG the
AVI quality (Image and Movie Options under the Options menu) will control the quality of the AVI
animation. AVI files use a lower default quality to achieve better compression. Because of the
motion, lower image quality is needed. When you select an AVI file for output, if the file exists,
the new image will be added to the end of the sequence. If the AVI file does not already exist
then a new AVI file will be created with only the new image. If the AVI file already contains the
maximum number or greater of frames (images) in the sequence then the first frame (or frames)
will be removed so that the total number of frames will be the maximum after the new image is
added.

Volume Control
When recording signals it is important that the volume is not set too high or too low. If the vol-
ume is set too high, clipping will occur and detail will be lost in the white areas of the image. If
the volume is set too low, some detail will be lost throughout the image.

The volume should be adjusted so that the vol which is displayed when the signal is processed is
between about 50.0 and 75.0. Higher numeric values of vol (e.g. 92.3) indicate that the volume
should be decreased, lower numeric values of vol (e.g. 24.7) indicate that the receiver volume
should be increased.

The volume will be displayed when a signal is being recorded. The volume on the receiver can
be easily adjusted during a satellite pass to set a reasonable vol. Note that it is not recommended
that the volume be changed during every satellite pass (as the resulting images will show bands
of light and dark). The volume should be set once and then left alone.

If using 8-bit audio files, the volume should be slowly increased until the vol shows between
about 85.0 and 92.0. Unfortunately, each satellite will require a different optimal volume setting.
Results will never be as good as images created from 16-bit recordings, especially where any of
the image enhancements are used.

If the volume is set very high, WXtolmg may issue a warning message.

Equipment Required
In order to make use of this program for APT transmissions you will need a receiver capable of
receiving FM signals in the 137-138MHz band (look for satellites at 137.30, 137.40, 137.50, 137.62,
137.80, and 137.85 MHz). A purpose designed weather satellite receiver is the best option as the
sensitivity and IF bandwidth (about 50kHz) will be correct.

Scanners and general purpose communications receivers can be used, however these often have a
very narrow IF bandwidth (close to 15kHz) with the result that whites (above about 128 on a
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scale of 0-255) invariably will be noisy and clipped. The narrow bandwidth will also cause a lot
of noise except when the satellite is straight overhead as the doppler-shift combined with the nar-
row IF bandwidth will result in a very poor signal. However, the upgraded versions of WXtolmg
adjust the frequency to compensate for doppler shift on supported receivers with an R5-232 con-
nection. Some communications receivers have a 30kHz (acceptable if the frequency is adjusted
using an upgraded version of WXtolmg) or 50kHz IF filter option, and there are modifications for
a few scanners to increase the IF bandwidth. A pre-amp can help with the poor sensitivity, but
these modifications may not result in the same image quality as a purpose designed weather
satellite receiver.

The upgraded versions of WXtolmg also contain special code to much more accurately build
colour enhancements when using narrow bandwidth receivers. The upgrade will be of consider-
able benefit to those getting reasonable images when using the Contrast enhance (NOAA ch B only)
enhancement.

A special antenna will be needed regardless of which receiver you have available. You can build
an antenna and there are several designs for the highly recommended QFH antenna available on
the Internet. Turnstile and crossed dipole antennas are other options.

You will, of course, need an audio cable between the "speaker out" of your receiver and the "line
in" on your sound card.

Finally, it may help to know when the polar orbiting weather satellites are passing overhead, so
you might want to obtain a tracking program. However, in record mode WXtolmg will let you
know the next satellite pass is expected.

For WEFAX transmissions from geostationary satellites, the most common method is to use a
small parabolic dish antenna, coupled with an active feed and down converter to convert the
1600 MHz band signal to the 137 MHz band. Then the same receiver can be used for these satel-
lites. See references for more information.

References and more Information
Paul Hayes has information on building a QFH antenna at:
http:/ /homepage ntlworld.com/phqfhl/qfh_diy_guide.htm

Also check out the information and FAQ on the WXtolmg home page at
http:/ /www.wxtoimg.com/

Terms and Conditions
The WXtolmg programs (which include wxtoimg, xwxtoimg, wxrec, wxmap, wxproj, and
wxbatch) and documentation are not warranted to be free of bugs. You should backup your sys-
tem before installing this software. Because of the nature of the analog signals and complex pro-
cessing performed do not expect results of this program to be correct in any or every instance.

The WXtolmg programs and documentation are supplied "AS IS". Central North Publishing
Limited disclaim all warranties, expressed or implied, including, without limitation, the war-
ranties of merchantability and of fitness for any purpose. Central North Publishing Limited
assume no liability for direct, indirect, incidental, special, exemplary, or consequential damages,
which may result from the use of the WXtolmg programs, even if advised of the possibility of
such damage.

The WXtolmg programs and documentation are not intended to be used where life, health, safety,
or property may be at risk.

The freeware edition of the WXtolmg software may be used for personal, non-commercial pur-
poses free of charge. Additional features are available only to those who upgrade their copies of
the software.

Use by any commercial organisation, or any individual for commercial purposes requires the pur-
chase of a professional edition upgrade key. An upgrade key may be obtained from:
Central North Publishing Limited
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P.O. Box 99597

Newmarket

Auckland

New Zealand

Email: http:/ /www.wxtoimg.com/email html
http:/ /www.wxtoimg.com/reg/

The WXtolmg programs and documentation may only be redistributed for personal use, on a
non-commercial basis, and in their original, unmodified packages. No other redistribution is per-
mitted. Central North Publishing Limited reserves the right to stop redistribution. Upgrade keys
may be installed on a single computer and may not be produced, distributed or disclosed to other
parties. You may install the upgrade key on a laptop in addition to the primary computer as long
as you only run WXtoIlmg on one computer at a time. You may not disassemble, reverse engi-
neer, decode or decrypt this software or make use of information, code or algorithms obtained in
this way.

The WXtolmg programs are Copyright (c) 2001-2010 Central North Publishing Limited. All
rights reserved.

Credits
Special thanks to Andreas Rehberg, Gerd Berg (DK1RR), John Boudreau, Adrian Chamberlain,
Ari Ervaskivi, Andy Eskelson, Jakub Gorzynski (SQ2WB), Les Hamilton, Paul Hayes, Paul
Holder, Nakato Mikiya, Pauli Nunez (EA3BLQ), Andre Phillips, Steven Ross, Jeremy Royle, Hart-
mut Schaksmeier and many others who beta tested the numerous early versions of this software.

NOAA provided a wealth of information on their web-site and in their publications, developed
most of the enhancement curves used in WXtolmg, and provided outstanding support.

Notices
Copyright (c) 2001-2010 Central North Publishing Limited. All rights reserved.

The ZA, MB, MD, BD, CC, EC, HE, HE JE J], LC, TA, WV, and NO enhancement curves were pro-
vided by the National Oceanic & Atmospheric Administration (NOAA).

JPEG support, in part, provided by the Independent JPEG Group.
Text overlay support based on the work of the FreeType Team.
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Calibration
WXtolmgmust be setup and calibrated to aehieseful results. Setup requires setting the location of your
recever and downloading the latesteflers. Calibratioimmust be performed in twareas: the first is the
volume of the recording, the second is to match the sampling fregtetihe sound card sample ratéou
need to perform this calibration only once.

Before you Begin

Simply connect your recar’s audio output to thdine input of your soundcard using a suitable calife.
you hare an ICOM PCR1000 receér, ensure that you foll the instructions in the manual for setting the
internal jumper for line el output (or alternatiely use the PCR100 setting instead).

The polar orbiting satellites transmit on 137.10, 137.40, 137.50, 137.62, or 137.9125 FM (50kHz or NFM)
and each satellite will pass by twice per day (about 12 hours apart) at roughly the same times. each day
You may be able to catch lower gtion passes about 1.5 hours before and after the best pass. Note that
all satellites will not be transmitting depending on on time of,teartime of daytheir proximity to other
satellites, and whether thare working or not. A good pass lasts approximately 10 to 15 minuiaten
WXtolmg is in record mode it will indicate the next satellite pass and the fregoamhich it is transmit-

ting.

Setting the Ground Station Location

SelectGround Station Locatiofrom the Optionsmenu. Entethe name of your city and countrif the
city you live in has a populationwer about 100,000 then click on the@okup Lat/Lorbutton. If you are at
sea, you can enteryadescription you lile for city and country.

If you could not lookup the latitude and longitude, then youllehs enter the latitude and longitude of
your location. Latitude and longitude must be entered in degrees and fractiogseafsd@.g. 52.500, not
52:30, nor 52:30:00, nor 52:30.00). North and east should be entered as pusitbers, south and west
should be entered asgaive numbers. Ifyou do not knw the latitude and longitude of your location, then
try the closest large city (population >100,000) and clickookup Lat/Lon If you do not knw the alti-
tude just enter 0.0.

Updating the Keplers

Current U.S. geernment regulations mean you should obtain an account from Space Track to gain access

to the Keplerian elements required for WXtolmigowever, a present you can use Celestrak without an

account (see Options -> Internet Options). Accounts are generally simple and fast to obtain from:
http://www.space-track.org/

Once you obtain an account, you will need to login to this account and change yowrgasBwenopen

Internet Optiongrom theOptionsmenu, and type in your Space Track username amgasgsword.

Now, connect to the Internet and selélfidate keplersfrom theFile menu to download the latest orbiting
elements for the weather satellitd6you do not hae an Internet connection, then ignore this and instead
selectDisable Map Overlayrom theOptionsmenu.

Checking for Satellite Passes at Your Location
SelectSatellite Pass Listrom theFile menu. Thiswill display a list of satellite passes from the current
time to 7 days ahead for your locatiofimes are gien in both local time and UTC.

Adjusting the Volume

Set the volume control on your ree@ito a low to moderate leel, then selecMixer Contol... from the

File menu. Configurghe mixer to tak input from the source the reeei is plugged into (normally the
Line In), set the PCM and Recording (cassetteldgLinux only) all the way to the top. Set the Linede

(Linux and Windows) at about the mid-point. Set the igain (Linux only) te itid-point. Itis better for
the volume and line \&ls to be too lar than too high to start with.

Under Windows 95 you may ha o slectPropertiesfrom the Optionsmenu on the Mixer control and
check theRecordingbutton, and check theine volume control before you can adjust the controls aseabo

SelectRecord..from theFile menu, and click oAuto Record

Wait for a satellite to arvie. WXtolmg will indicate when the satellite is expected (in UTC) and on what
frequeng the satellite is transmitting in the status bar.
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WXtolmg will record the pass -- during the pass an image may henshim not be concerned with the
brightness or darkness of the image or other problems such as it consisting only of diagoné/Hieres.
setting the volume wer use this image as a guide -- use only the volume setting discussed Bdter
recording is complete WXtolmg will build a map and re-decode the imiagees this to produce the best
possible results.

Avoid using the scrollbars to scroll the image while recording -- this can cause the resulting image to be
split.

The program volume (vol) will be displayed when the signal is being recotfiedsatellite is passing
overhead and the status line indicates that the program is still waiting for carrier or waiting for signal then
the recerer volume may be too 1@ or the mixer input leel may be set too le. Jowly increase either or

both until the status line indicates the signal is being recorded. The volume on ther (ecehe record-

ing level on the mixer) can then be easily adjusted during the pass to set a vol between 50.0 and 75.0. If the
recever has no volume control or the volume control does not affect the speaker output, then adjust the
mixer settings (recording, &n, or input line leel) until the displayed vol is between about 50.0 and 75.0.
The volume bar should be green when a signal is beingredceéd or yellav indicates the volume is too

high or too lov.

The image will be re-decoded after the satellite has passed. When the decode is compietalithel-o
ume will be shown on the right hand side of the status linevitel® image.

The overall volume should be between about 40.0 and 8Bigher numeric values of vol (e.g. 90.2) indi-
cate that the volume should be decreased, lower numeric values of vol (e.g. 24.7) indicate thatnthe v
should be increased.

If the wolume is set too high, clipping will occur and detail will be lost in the white areas of the iitfiage.
the volume is set too\wg some detail will be lost throughout the image.

Except for this calibrationvaid adjusting the volume when the satellite is passuaghead. Adjustinghe
volume during a pass will produce banding in the final image and willradly affect temperature calibra-
tion.

Adjust the volume appropriately and repeat.

Adjusting the Sampling Frequency (Slant Correction)
Start by selectindisable PLLfrom the Optionsmenu. Disablinghe PLL allavs us to properly set the
sampling rate.

Next, select a recording to decodBelectOpen Audio Fe... from theFile menu, and choose a recording.
Ideally youd like a ecording from a satellite on a highieshead pass.

Now, wait for the image to be decoded and displayEde image will be bent slightly from top to bottom
as a result of the doppler shift. This is normal when the PLL is disabled.

SelectSlant Corection...from thelmage menu. Scrolto the top of the image and click on a vertical edge
in the image. Continue holding the button down and drag a line to the bottom of the illaye.the
image to scroll until you get to the bottom of the image. Ensure the pointar ihe same edge that you
originally clicked on and release the button.

A dialog box will pop up and display the suggested sampling fidte.WXtolmg program can estimate the
sampling rates for all other satellite¥ou should select thé&stimate and set sampling frequencies for all
satellitesoption if it is not already selected, then click et

Un-selectDisable PLLfrom the Optionsmenu. Themage will be re-decoded and should be completely
straight. Ifit is bent or jagged, ensure that yowdan-selectedisable PLLin the Optionsmenu. Ifit is
slanted, then try repeating the process, paying close attention to these instructions.

While options are (by datfilt) saed on «it, you should ensure the sampling frequencies aredsiy
selectingSave Optionfrom theOptionsmenu.
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Copyright
Copyright (c) 2001-2010 Central North Publishing Limited. All rights reserved.

version 2.10.10 3



WXTOIMG(FAQ) WXTOIMG(FAQ)

Recording
Why do | get a message Warning: couldn’t find telemetry data when WXtolmg displays an image?
You reed to adjust the sampling frequgndénformation on adjusting the sampling frequenan be found
in theRequied Calibation...document under thidelp menu. Alsosee theSlant Corectionsection in this
manual.

Why do | get Error: wavelnOpen failed! when WXtolmg tries to record?

OpenRecod Optionsin the Optionsmenu, and change the soundcaraief your PC only has one sound-
card you may need to change this for recording adkjv Click OK and enter record mode again to test.
Try al soundcard values until you find one thairks. Ifthis fails to eliminate the problem you may need
to install or re-install the latest ders for your soundcard.

Why does recording n&er start?

Ensure that the audio cable from the regreis atached to the soundcard Line 1 inp@Ensure that you
have wsed the speaker (and not line) output from the veceiFollow the instructions carefully in the
Required Calibration..section under thelelp menu.

Why is the image split (sometimes referred to as sync loss)?
The image looks as though it has been cut horizontally and the upper or lower portion shifted left or right.
This may occur in just one place or in multiple places in the image.

UnderOptions enableResynavhich will correct most of these problems.

However it is best to minimise the occurrance of these splits in the first place. The problem is caused by
other programs doing a lot of adty or using a lot of CPU or memory or performing a lot of disk i/o while
WXtolmg is recording. Limiting the number and activity of other programs while WXtolmg is recording
should eliminate the problem. Some screemsacan also cause this problem, so setting your scrgen sa

to none would be a good idea.

Why does the program hang with a Status: opening soundcard... message?
The soundcard is in use by another program (possiietytae mixer). Closeother programs (including the
mixer if it is running).

Why does recording start immediately and neer stop recording when | try to record signals flom
polar orbiting satellites?

Most likely your receier does not hee gjuelch on the audio out. Select either Rexod when 2400 Hz
carrier presenor Recod only when selected active APT satellites arerheadmode.

Why does it never stop recording when | try to record signals from geostationary satellites?
You need to select thRecod using WEFAX start/stop ton@sode in theRecoding Options..dialog under
the Optionsmenu.

Why do | only record every other image from geostationary satellites?

Processing is taking too longfou can reduce processing time by disabling Options -> Despeckle (or set-
ting it tonong. Despecklés generally inappropriate on WEK images because it degrades the fine lines
in the maps. Setting Options -> Sharpendoewill marginally improve processing speed.

You can further reduce processing by settvigximum number of thumbnails 0 in GUI Optionsin the
Optionsmenu.

Also ensure that you kia rot selectedJse for audio ecodings/maps todn File Names and Locations
under theOptionsmenu. Renaminghese files requires significant extra time. Finally reduce the number
of autoprocessing images and steps performed lRetmrdin theFile menu.

If your computer still isrt’ fast enough to complete processing before the next imagesasonsider

upgrading your computerAlternatively you can selecRecod only (show imge if enabled)from Record

under the File menuln this mode, only audio files can bevad, but the program will shothe image as it
is being recorded.

The program tries to record polar satellites at the wrong time, what needs to be done?
Check your time and timezone setting are corr€t.Wndows open the Date/Time control panel (Start ->
Settings -> Control Panel -> Date/Time), ensure that the "Time zone" is for a nearbyhaity
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"Automatically adjust clock for daylight savings changes" is selected, and that the time is correct.

On Windows, check youautoexec.batile for a setting starting witBET TZ= This will override the time-
zone settings set in theildows control panel and can cause problems for WXtolRgmaove te line or
comment it out.

How can | automatically remove the older images and recordings?

SelectRecordfrom theFile menu. Therare separate options for when to remeudio files, rav images,
maps, and imagesChoose a time for these to be delet&glectAccept then selecBave Optiongrom the
Optionsmenu. Notethat files are only deleted if thénave been created automatically by WXtolm{.
you useSave Imge & or Save Raw Inge @ the files created will not be automatically deletédidio
files created by other programs will also not be deleted.

Image Slant
Why do | get a message Warning: couldn’t find telemetry data ?
You reed to adjust the sampling frequgndénformation on adjusting the sampling frequenan be found
in theRequired Calibration..document under thidelp menu. Alsosee belw.

Why are my images slanted?
You reed to adjust the sampling frequgndénformation on adjusting the sampling frequenan be found
in theRequired Calibration..document under thidelp menu. Alsosee belw.

| can't find a vertical edge in the image to use for slant correction.
Ensure you hae ®lectedDisable PLLfrom theOptionsmenu, and then select&tant Corectionfrom the
Image menu.

This is because your soundcard is sampling very far from the 11025 Hz that it should be. Thigdn’

lem. Your image will hae doping horizontal lines running through itnstead of dragging a line along a
vertical edge, just drag a line along one of the sloping (near horizontal) lines from left to right across the
image.

Next selecEstimate and set sampling frequencies for all satelfitebsclick onSet
ChooseDecodefrom theFile menu and repeat the procedure. This time the edges should be near vertical.

Remember to ensui@isable PLLis not selected and then cho&ave Optiongrom theOptions Menuo
save the slant correction settings.

Map Overlays
Can WXtolmg produce map overlays from recordings made by other programs?
Yes. However it may be necessary to chargjedio file namingo Other, in the File Names and Locations
dialog under th®©ptionsmenu. Thisften needs to be dongen if the filenames are MMDDHHMM.awv
(month, dayhour, minute) because WXtolmg requires that this date be the time of the start of the recording
and not the time when the satellite caraer the horizon.

Why do | not see map werlays and often get a message that WXtolmg could not find matching pass
to build overlay map ?

Ensure that you ve st the latitude and longitude und&round Station Location..in the Optionsmenu
to match your location.

Also check that the appropriate satellite type is selected irAthige APT Satellitesub-menu in the
Optionsmenu.

It could also be that your computedock is of significantly (5 minutes or more)SeeWhy ae the maps
never aligned correctlipelow.

Finally, your timezone setting may be incorrect so that the calculation of UTC time will not be c@rect.
Windows open the Date/Time control panel (Start -> Settings -> Cordred|P> Date/Time), ensure that
the "Time zone" is for a nearby citthat "Automatically adjust clock for daylight savings changes" is
selected, and that the time is correct.

Note that the Ground Station Location, needed for generating maps, is not used in determining UTC time.
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Why are the maps neer aligned correctly?

The most common cause is that the compsiock is of by more than a 250ms (a quarter of a second).
In order for werlays to be aligned accurately the compustelock must be very accurately seédn Wn-
dows XP and Vihdows Server 2003, WXtolmg can set the clock to an Internet time so8esnternet
Optionsin theOptionsmenu. Upgradedersions of WXtolmg can synchronise the B@bck to a GPS.If

you are recording on a different computben the clock on the recording computer must be set correctly.

My clock is accurately set, what other causes arthere?
Using out-of-date Keplers will also cause the maps to be incorrectly alignstiuse th&pdate keplers
option under thé&ile menu.

Also if you use recordings that were copied from some other place, then the timestamp on the recording
may be affected resulting in maps which are significantly mis-aligned. Look forygoomgram that pre-
serves time-stamps (under *NIX use cp with the -p option, or use mv instead).

What can | do about orerlays that are gill missing or not correctly aligned?
Use theMove Overlay..option under thémage menu to maee incorrectly aligned eerlays.

On Windows, check youautoexec.batile for a setting starting witBET TZ= This will override the time-
zone settings set in theildows control panel and can cause problems for WXtolRgmaove te line or
comment it out.

Check that your Internet finall is configured to allev connections from WXtolmg (xwxtoimgxe), so that
the Keplers can be updated.

Keplers
How often should | update the Keplers?
In order to @oid having to mee the map werlay, Keplers should be updatedesy few days. Connecto
the Internet, then seledpdate Keplerdrom theFile menu.

| cannot update the Keplers, whats wrong?

Check your Internet connectiolif. it is OK and Update Keplers fails it is likely because your Internet fire-
wall is not configured to alle xwxtoimg.exe b make @nnections to the Internet (via HTTP port 80).
Check your Internet fireall manual for details.

| do not have access to the Internet, hav can | update the Keplers?

If you have email access and can get the Keplers emailed to you or sent op disppr other media, then
simply coy a file of two line elements into \Documents and Settings\...your name...Olication
Data\WXtolmg\weather.txt under Windows, or “/.wxtoimg/weather.txt under *NIX.

General
Why do | get the waming message enhancement ignored: could not find a NOAA sensor 2 (or 3)
image ?
The operational NOAA satellites send images from $nsors. Ahight, images from sensor 3 (mid/ther
mal infrared) and sensor 4 (thermal infrared) are sBuiing daylight (and dusk) sensor 2 (visible/near
infrared) and sensor 4 (thermal infrared) are s@ihie warning indicates that the enhancement yme ha
chosen (from the Enhancements menu) requires a sensor whichvsiladilein the current image. In this
case WXtolmg ignores the enhancement chosen and produces a "Normal" enhancement image instead.

I’'m using WXtolmg under Linux, and the font sizes are very large (or very small) in some places.
This is because the monitor size is not set correctly in youringlds configuration.You will need to
add a line (or correct the existing one) that describes your monitor width and height in mm. Edit the X-
Windows configuration file (often /etc/X11/xorg.conf) and in the "Monitor Section" add:
DisplaySize 330 210

replacing 330 and 210 with the width and height of your mositoreen in millimeters. Then logout and
log back in.

Why do i get a Runtime Error! ?
If WXtolmg crashes with a message from the "Microsoft Visual C++ Runtime Library", stating that there
was a 'Runtime Error!" and that "This application has requested the Runtime to terminate it in an unusual
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way. Please contact the applicatisrupport team for more information”, then youvbaa vdeo drver
problem.

Obtain and install the latest ders for your graphics card/chipseit most cases this will sadvthe prob-
lem. However, the issue surrounds displayingdarimages or manthumbnails in WXtolmg, so you can
work around the problem, by decreasing keximum number of thumbnails GUI Optionsto 100 or less
(sometimes 50 or less). And if you are performing image projection changes, by redudingj¢agon
scale

How can | get images that shar exactly the data that was recaied from the satellite?
SetEnhancemerntb Pristineand enabl&how Allin theOptionsmenu.

Can | process old VAV files from satellites that haen’t transmitted for a long time?

Yes. Firstenable expert mode iUl Optionsunder theOptionsmenu. ExitWXtolmg and start it agn.
Now select the satellite you wish to process th&\AH file for from theSatellitemenu. Operthe WAV E
file usingOpen Audio Filen theFile menu.

If the program fails to build a map, it is ¢y because the date/time stamp on th/®/file is not correct.

You'll need to ensure the file is named YYYYMMDDHHMMSSwfor the UTC time it was recorded

(i.e. 19990928025912) for 28 September 1999 02:59:12 UTC. Be as accurate as possible with thie time, b
generally +/- 5 minutes will be OK (lever you will have o move he map usindg/iove Map Overlayrom
thelmage menu). Nev openFile Names and Locatiofeom theOptionsmenu and sefAudio file naming

to YYYYMMDDHHMMSS UTC tim€lick OK. Finally open your renamed file using Open Audio File.

Why are some menu items gray and not selectable?
These items arevailable only in the upgradeckvsion. Informatioron upgrading is\ailable at:
http://www.wxtoimg.com/reg/

Note that while in record mode or when images are being processed all of the optaptélelp, Stop
andExit are gray.

How do | display local time instead of UTC time?
This applies only to copies of WXtolmg with an upgraeg kstalled. Disabl¢he Show time as UT&et-
ting in GUI Optionsin the Optionsmenu.

To change time on the texverlays (only), OperTex Options from the Options mentiReplace UTC with
%@%Z or Y%@local or use %@ followed by your time zone 8@EST). Sele@®K.

Hints for impr oving image quality.

If you are using a narwo bandwidth scanner or communications reeeithen purchase an upgradeyk
openRecoding Options and setreceiver typeto Scanner Communications By doing this, the softare
will use special processing modes to dramatically imgimage quality with colour enhancements. If you
have a @mputer control cable for your regei and the receier is shown in the list, then select the specific
recever instead. Egn better images will be obtained when WXtolmg can control theveecdurchase
the upgrade only when youveadearly recognisable images using tBentrast enhance (NOAAB mly)
option.

For APT images sdbespeckldgo 2.0 in theOptionsmenu to help eliminate some of the random noksa:.
WEFAX imagesDespeckleshould usually be set tione

On upgraded versions, $dtnimum Solar Elevation for visible irges to 15.0 in theRecorddialogue in the
File menu.

Setlllumination Compensatioto Full or Medor ary other choice thadonewhenContrastis set toLinear
(constant)

If you are producing an image for printing, €&gmmato nonein the Optionsmenu, and se the file as a
PNG file (by placingpngon the end of the filename).

If you are creating movies/animations, 8 Codecto RGBin Image and Movie Optionsn the Options

menu. Thiswill create much larger animations, but will greatly imgrdhe quality Note that you'll hae

to delete your existing animations before the change takes effect (the codec is only set when the animation
is created for the first time).
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When using one of the Anaglyph enhancements fromAAl@atellite passes at dusk or night, endliée

other sensom the Optionsmenu. Alscsare your anaglyph images #NG or BMP files (just use gongor

a .bmpextension. Thisis usually necessary because the lossy JPEG format can cause colour shifts that
adversely affect the 3-D effect.

To remove the noisy portions of the image at the top and bottom, opeReheding Options..dialog in

the Optionsmenu and seled®ecod only when selected active APT satellites arerhead then setecord

only when satellite is above @ees)to about 15. This will ensure that recording only takes place while
the satellite is at least 15 degreesvabibe horizon. Note that the bestlve will depend on your eimon-
ment and receiving equipment (values between 8 and 18 would be typical).

How can | create images that | can import into Digital Atmosphere?

This applies to upgraded versions oninableDA compatible BMP formaith Image and Movie Optionsn

the Optionsmenu. SeProjectionto Orthographic OpenProjection Optiondrom theOptionsmenu. Set

Scaleto 640 (or if youwe changed the map width use the width of yodr map is in pixels). Lookat the

DA map and guess as closely as possible the most northern and southern latitudes and the most eastern and
western longitudes (in degrees and decimgleles). Usé¢hese values (getive for south and west, posi-

tive for north and east) for the North, Southedty and East boundaries. SetReeence Longitudéo the

longitude at the centre of theADmap. Setthe Refeence Latitudeo the latitude at the centre of thé\D

map.

How do | print an image?

Because WXtolmg has no built in prirtcilities, you must first sa the image to a file (seleSave Imge

As under theFile menu). Endhe filename with .png or .bmp to create a PNG or BMP image rather than
the default JPEG (this will impve print quality). You may also want to s&ammato nonein the Options
menu before saving the image. Once the image has besthysa can open it with a variety of programs,
including photo editors or your Internet browser and print it.

Why do the colours on my screen go strange when | run WXtolmg?

This is because you Y a gaphics adapter set to 256 Color (8-bit) mode. WXtolmg grabs all 256 colours
for it's awn use -- which allows it to display much better imagésu could try changing the display set-
tings to True Color (24 or 32 bit) or High Color (15 or 16 bif)your display adapter is not capable of
more than 256 colours and you really disltkis feature, it can be disabled by un-selectisg private col-
ormap underGUI Optionsin the Optionsmenu. Remembdp Save Optionsthen exit and restart the pro-
gram.

What does northbound 51 W mean?

This is a description of the satellite pass. Southbound or northbound indicates the direction the satellite is
traveling. Themaximum elgation (in this case 51 degrees) ivayi next. Notethat the maximum ele-

vation will be between 0 and 90 degrees (with 90 indicating a divedhead pass)This is followed by an

either E (east) or W (west) to indicate if the satellite igtitag to the east or west of you (at the time of the
maximum elgation).

| just want a nice false coloured image. Hodo | do that?

During the summer when images are well illuminated by the sun, the MSA Multispectral analysis, HVC,
and HVCT enhancements on NOAA satellitegeggpod results. Select these under tghancements
menu.

During the winter or summeday or night, the MCIR and NO enhancements on NOAA satellitess gi
good results.

What does WXtolmg mean?
WXtolmg is shorthand for "WX to image" (weather satellite to image).

AV Animations
Can | build movies from polar orbiting satellites?
Yes, if you hae purchased the upgrade. Hexébw to do i:

Open thelmage aad Movie Options..dialog under théptionslIf you would like high quality movies or
wish to viev 3-D movies using one of the Anaglyph enhancements you might t@ change thé&vl
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Codecto RGR (This will result in movies which are very large, but will pide a better 3-D &ct.) Oth-
erwise use th&1JPGcodec. SeledDK.

Open theRecorddialog from theFile menu. Ensur¢hatRecod and auto pocesss selected.EnsureCre-
ate Movie(s)s selected. Then click on tivdovie Settingsutton.

Select the enhancements you woule lir the meie. A movie will be made for each selected enhance-
ment. Thebest enhancements for AVI movies wouldMEIR map colour IR (NBA), Contrast enhance
(NQAA ch B mly), Sea Surface emp Anaglyph false 3-D Colour anaglyph false 3-DNO colour IR
enhancementnd ZA generl IR enhancementYou may also get reasonable results withHIWC false-
colourandHVCT false-colouenhancements.

Click on theEasy Set Defaultsutton.
SelectSet

Set theMinimum pecent of projection filledo 50.0 so that frames with less than 50% of the pixels filled
will not be added.

Now click on theRecordbutton. Each time a satellite passes a frame will be added tiefsp You can
view the movies that ha keen produced by selectivMiew Movie from theFile menu.

Can | build movies from a bunch of old images, raw images or recordings?
Yes, if you hae purchased the upgrade and if using processedwinnages, the images were produced by
WXtolmg.

SelectLinear (constantfrom theContrastsub-menu in th®ptionsmenu. Thishelps to ensure that each
frame in the animation will k& smilar brightness and contrast.

SelectFull from thelllumination Compensatiosub-menu in th®©ptionsmenu. Thisalso helps to ensure
that each frame in the animation wilMeasmilar brightness and contrast.

Open thdmage and Movie Options. dialog under th®ptionsmenu. Changéhe AVl Scaleto 1.00Q (If
you wish to alter the size of the mie, use théProjection Scalén the Projection Optiongdialog under the
Optionsmenu instead.)f you wish to viev 3-D movies using the Anaglyph enhancement you migdritw
to change thé&Vl Codecto RGB (This will result in m@ies which are very large, but will provide a better
3-D efiect.) Otherwisaise theMJPGcodec. SeledDK.

Open theProjection Optionsdialog from theOptions menu. Yu can change th€ente Longitudeif
desired to some longitude near you, ovéeablank. Naw set the North, South, West and East boundaries.
Try setting them to about 10 degrees north, south, west and east of your lotaiibnde and longitude
must be entered as a decimal number grekes and fractions of geees. Useositive rumbers for north
and east, rggtive rumbers for south and wesYou must enter a value for all four bounds. Selget

Under theProjectionmenu, seledvlercator (or ary projection other thaformal).

Under theEnhancementenu, select then enhancement yantito use for the nwie. Thebest enhance-
ments for AVI movies would b&CIR map colour IR (N®A), Contrast enhance (NOAAMB mly), Sea
Surface €mp Anaglyph false 3-DNO colour IR enhancemerand ZA geneal IR enhancementYou may
also get good results with ti#/C false-colouandHVCT false-colourand Vegetationenhancements.

Now open a recording usin@pen Aidio Fle, a mw image usingdpen Raw Imge, or a pocessed image
using View Image from the File menu. Whenprocessing is complete, selegave Imge from the File
menu. See the file to an AVI movie by setting the filename extensiomo(e.g.noaa-za.av.

Repeat the previous step for other recordings,inaages, and movies, saving them to the same filename.
When prompted towerwrite the file, selecyes AVI movies are not werwritten, instead a frame will be
added to the end of the movie.

When you hee alded all the images, selédew Movie from theFile menu and select the file you just cre-
ated.

OK, but isn't ther e an esier way to build many different AVIs from old images?
Yes. Follow the instructions fo€an | build movies from polar orbiting satelliteb@t in the last step, click
on theAcceptbutton rather thafRecordbutton.
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Now open a recording usin@pen Aidio Fle, a mw image using@dpen Raw Imge, or a pocessed image
using View Image from the File menu. Onceprocessing is complete, selettito Processfrom the File
menu. Repeat.

| cannot display the AVIs using Windows Media Player.
Unfortunately older versions of the Wdows Media Player do not support the MJPG (Motion JPEG)
encoding which is the default in WXtolmg version 1.0 andvab@é special codec is needed folintfows
Media Player to play these file¥ou can get this MJPG codec by installing Microsoft Directefsion 8.0
or abae. Available from:

http://www.microsoft.com/directx

Note that Vihdows 95 users must dmload a different version of Direct X, andilows XP users do not
need to install this.

If you still have frouble, check your display settings (Start -> Contaoid? -> Display -> Settings, or on
XP: Start -> Control &nel -> Appearance and Themes -> Display -> Settings) and set the colour quality to
32 bits or 24 bits.

Alternatively, the Apple Quicktime player for Windows works fine. It igitable from:
http://www.apple.com/quicktime/download/

Finally, you could selectmage and Movie Options..from the Optionsmenu and seAVl Codecto RGB
This will createvery laige uncompressed animationgjtithis format is supported by almostesy AVI
viewer.

Note the Linux/*NIX xanim player supports the MJPG encoding method used.

Can | build movies of images from geostationary satellites?
Yes. Heres how to do it:

First, open thdRecoding Optionsdialog from theOptionsmenu. SelecRecod using WEFAX start/stop
tones SelectOK.

SelectLinear (constantfrom theContrastsub-menu in th®ptionsmenu. Thishelps to ensure that each
frame in the animation will k& smilar brightness and contrast.

Open thelmage and Movie Options..dialog under théptionsmenu. Sethe AVl Scaleto 0.50Q Select
OK.

Open theRecorddialog from theFile menu. Ensur¢éhatRecod and auto pocesss selected.EnsureCre-
ate Movie(s)s selected. Then click on tihdovie Settingsutton.

Set theMovie Filename Template %s-%l-%C-%e

Select the enhancements you woule Iflar the maeie. Only some of the enhancements apply to geosta-
tionary satellites. If in doubt, just selédbrmal SelectOK.

Now click on theRecordbutton. Eachtime an image is decoded from the satellite it will be added to the
appropriate movie. A different mi@ will be created for each secteach sensor and each enhancement.
You can viev the movies by selectingew Movie from theFile menu.

Composite Images
Can | automatically build combined images from multiple satellite passes?
Yes, if you hae purchased the upgrade. Hexébw to do i:

First, open th&kecoding Optionsdialog from theOptionsmenu. SelecRecod only when selected active
APT satellites a overhead SelectOK.

If you wish to create composite images using the HVC, HWERnaglyph enhancements you migham
to select théJse other sensan the Optionsmenu.

Open theRecorddialog from theFile menu. Ensur¢éhatRecod and auto pocesss selected.EnsureCre-
ate composite ingg(s) is selected. Then click on ti@mposite Imge fttingsbutton.

Select the enhancements you woule ik ceate composite images for.
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Click on theEasy Set Defaultsutton.
SelectSet
Note that thevlinimum percent of projection filledbes not apply to composite images.

Now click on theRecordbutton. Each time a satellite passes the images wilvbdaid on the composite
images. ¥u can vigv the composite images thatveabeen produced by selectingew Image from the
File menu.

Can | build composite images manually?
Yes, if you hae purchased the upgrade.

SelectLinear (constantfrom theContrastsub-menu in th®©ptionsmenu. Thishelps to ensure that part of
the composite image will ka smilar brightness and contrast.

SelectFull from thelllumination Compensatiosub-menu in th®©ptionsmenu. Thisalso helps to ensure
that each part of the composite image willdnamilar brightness and contrast.

Open theProjection Optionsdialog from theOptions menu. Yu can change th€ente Longitudeif

desired to some longitude near you, oréeblank. Nav set the North, South, @6t and East boundaries.

Try setting them to about 30 geees north and south, and about 30 - 40 degrees west and east of your loca-
tion. Latitudeand longitude must be entered as a decimal numbeghe@®and fractions of geees. Use
positive rumbers for north and east,gave rumbers for south and wes¥ou must enter a value for all

four bounds. Sele@et

Under theProjectionmenu, seledvlercator (or ary projection other thadormal).
Under theEnhancementsienu, select then enhancement you want to use for the composite image.

Now open a recording usingpen Audio ie, a mw image using@pen Raw Imge, or a pocessed image
(from WXtolmg) usingView Image from theFile menu. Openingudio files or rv images will generally
result in better results. When processing is complete, seteuposite Imge © from theFile menu. Bet-
ter results can be achisl by saving to PNG or BMP files (set the filename extensiompibgor .bmp(e.g.
noaa-2401.png

Repeat the previous step for other recordings,inaages, and movies, saving them to the same filename.
When prompted towerwrite the file, selecyes Composite images are novawritten, instead the me
image will be eerlaid over the previous one.

Better results may be achel by saving the lower elegtion passes first and the higheswveli®n pass last.
This ensures that the best images og@agnuch of the composite image as possible.

When you hee alded all the images, selédew Imagefrom theFile menu and select the file you just cre-
ated.

Creating Web Pages
Can | automatically create web pages and publish them?
Yes. Heres how to do it:

Open theRecorddialog from theFile menu. Ensur¢hatRecod and auto pocesss selected.EnsureAdd
images to web pajeis selected. Then click on tigeb Page ®ttingsbutton.

If you have purchased an upgradeykleare the HTML Templatealone for nov.

Select the enhancements to use on the web page. Wieeal mhancements are chosen, the firaitable
enhancement is usedry "MSA,MCIR,contrast”, then if the MSA enhancementysilable this will be
used, otherwise the MCIR enhancement will be usediifable, otherwise just a contrast enhanced image
will be used.

Choose a thumbnail size. Using 20.0% is recommended, although in some cases you miglgtefind lar
thumbnails (25.0%) look better.

TheHTML Filenameis the name of the HTML file that will be created. If unsureyddhais asindex.html
Most Internet Service Providers (ISPs) provide free home page actiessk with your ISP about setting
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up a home page if you are unsuiaur ISP should provide you with: the hostname for FTP access to your
home pageHostnamg, a username or login for FTP access to your home pisg)(and a password for
FTP access to your home pagessword. Enterthis information in the locations provided.

For the Directory you should enter the directory where your web page should be plHabé. directory
does not exist WXtolmg will attempt to create Your ISP may be able to help you choose the directory
name for use with FTPSometimes it needs to begin with "/public_html/" or "/htmi/".

If you hare an "always on" Internet connection, check the faxomatically FTP as imges are added this

tells WXtolmg to update your web page immediately and automatically after each satellite pass is decoded.
If you do not select this option you can manually update your web pagg ainanby selectindJpdate

Web Pagefrom theFile menu.

Although this \aries considerably from ISP to IS@ur web page may be accessed using a URL similar to
(replacingHostnameUser, and Directory):

http://www.Hostname/User/Directory/index.html
or

http://www.Hostname/"User/Directory/index.html

Contact your ISP for more information about using FTP to load your own home page.
If you dont want to publish the web page, you can create it in a folder or directory on your computer:
Ensure the the baRlace web pge into folderis checked.

Enter the folder where youowld like the web page built, you can click tBeowsebutton to select an
existing folder TheHTML Filenamewill be built in this folder (typicallyindex.htm).

After entering the FTP settings and/or the folder settings, gelect

You should be back at thRecorddialog. Ensureghat "Create Image(s)" is selecteldow click on Image
Settings In the Enhancements section you should select the enhancement(s) you ckasarficement to
usein theWeb Page ®ttings

Click OK.
Now click Accept
Finally selectSave Optionfrom theOptionsmenu.

SelectRecordfrom theFile menu. Each time a satellite passes the images and thumbnails will be created
and a web page will be built.

How can | impr ove the quality of the images on my web page?
For the Enhancement to us@Veb Page ®ttings under Recordin the File menu), select an option that
includes visible light imagery (e.y1SA, MCIR, contrajt

Set theMinimum solar eleation for visible imges setting (upgraded versions only unécordin theFile
menu) to aboul5 degrees. Thiswill eliminate poorly lit visible images from being presented on the web

page.
If you have slected a projection other thadormal set theMinimum percent of jection filledsetting

(upgraded versions only und@ecordin the File menu) to about 66 percent. This will peat images with
only a small fraction of the image filled from being presented on the web page.

UnderRecoding Optionsin the Optionsmenu mak aure Recod only when selected active APT satellites

are overheadis selected.Setwith maximum elevation above {glees)to about 30 to prent low elevation

passes from being recorded and presented on the web fadesetrecord only when satellite is abe
(degrees}o about 15 to crop the noisy top and bottom sections of the image when the satellite is not high
enough to recee a god signal.

How can | present time as local time on my web pages?
If you have purchased the upgrade, opéfab Page ®ttings from the Recdrdialog under the He menu.
Click the Browse button after HTML Template and select template2.htmk @icthen clik Accept.

If the time is also displayed on the images (tesdrlay), then operfesx Options fom the Options menu.
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Replace UTC with %@%Z or %@Iocal or use %@ followed by your time zgn&s@EST). Seled®K.

Can | change the web page layout, number of images, or information on the web page?

Yes, if you hae purchased the upgradén Web Page Sttingsin Recordunder the~ile menu you will find

an option for theHTML Template This template is the HTML document used to create the web prage.

can try the other templates pided (note that the web page will not change until after the next satellite
pass).

Or you can create your own templatéou may wish to look at the detilt (templatel.html) document as a
guide. You can cop this file to another and edit it.

The web pageldHTML filenameis created from theHTML Templateby substituting text within the tem-
plate.

The text imag¥.jpg will be replaced with the name of an image created by WXtotingnbX.jpg will be
replaced with the name of the corresponding thumbngithould be a number 1 or greatdthe most
recent image will be usé equal to 1.You should not lege any @ps in the image numbers. If you want 4
images on your web page then you shouldehaferences tamagel.jpg, image2.jpg, image3.jpg, and
imaged.jpg and likely the 4 corresponding thumbnailthumbl.jpg thumb2.jpg thumb3.jpg and
thumb4.jpg

Information text about the satellite pass or ground station can also added to the weblH&@HX,Y) in
the template will be replaced with the info corresponding to in¥a@s abee the most recent image is 1).
Y is a number which indicates the
information desired (chosen from the list v@Jo Therecan be no spaces in this string.g. INFO(2, 4)
will not be replaced.For Y=4 or Y=44 an optional extra argument can be used which specifies the
date/time format (e.g. INFO(1,44,%Y/%m/%d %H:%M %Z2)).

Y Description

0 width of image (in pixels)

1 height of image (in pixels)

2 width of thumbnail (in pixels)

3 height of thumbnail (in pixels)

4 time of satellite pass (UTC)

44 timeof satellite pass (local time)

5 satellite name (e.g. NOAA 17)

6 maximum el@ation of satellite pass

7 a&imuth at maximum eletion (E or W)

8 direction of pass (northbound, southbound)

9 enhancement used (e.g. MSA)

39 full enhancement name (e.g. Multi-Spectral Analysis Enhancement)

10 groundstation location

11 latitudeof ground station

12 longitudeof ground station

13 frequengin MHz (e.g. 137.62)

14 projectiomame (e.g. Mercator)

15 channeh (e.g. 3)

16 channeB (e.g. 4)

17 languagée.g. en)

18 characteset (e.g. is0-8859-1)

19 wxtoimgversion number (e.g. 2.4.15)

20 recever (e.g. R2FX)

21 pasguration (e.g. 14:59)

22 solarelevation (e.g. 23.3)

23 antennaype

24 estimatedime of publication (UTC)

64 estimatedime of publication (local time)

To dsplay information about future satellite passes on your web site you can use X=sif{2.X=-1
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being the net satellite pass. Y=24 and Y=64 apply only to future satellite passes. The optional date/time
format argument can be used with Y=24 and Y=64 as well as with Y=4 and Y=44.

Any of the following can be used in the optional date/time format:
%a abbreiated weekday name
%A full weekday name
%b abbrgiated month name
%B full month name
%d dayof the month
%H hourusing a 24-hour clock
%I hourusing a 12-hour clock
%j dayof the year (001-365)
%m monthas a number
%M minute
%p am/pnmdesignation
%S second
%y yearwithout a century
%Y yearincluding the century
%Z timezone name or abbreviation
%% a'%’ character

Copyright
Copyright (c) 2001-2010 Central North Publishing Limited. All rights reserved.
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Upgrade
How do | upgrade?
Point your browser at:
http://www.wxtoimg.com/reg/

and follov the instructions.For a anall fee you will be sent a personal upgragg kat you can use to
enable additional features.

Why should | upgrade?
Upgrading helps makcontinuing deelopment possible. Additionally, by upgrading additional features
become waailable.

There are tw upgrade editions, the Standard Edition and the Professional Edition.

What additional features are enabled when | purchase the Standard Edition *?
Anaglyph 3-D enhancements. These can provide a stunning waywifgithe cloud layersThey must
be viewed with special red/blue glasses.

Adds enhancements with (estimated) precipitatiegrlays. Notethat the precipitationwerlays will not
function with narrev bandwidth receiers.

Improved image quality for narse bandwith recaiers (e.g. scanners, communication reees).
Web pages may be completely customised when you upgrade.

Enables maynother projections (geographic transformations) including the Mercator Projection along with
enabling options (such as the centre or reference longitude, scale and boundaries) for controlling the trans-
formation of images from APT satellites.

Allows for the creation of animated mies of the images from multiple polar satellites (moving cloud, sta-
tionary land).

Composite images can be created from multiple polar satellite passes sovas adarge area.
Enables image rotation cababilities along with colour shifting and grayscalersion.

Allows a GPS (NMEA) to be used to automatically set the latitude and longitude.

Allows local time (instead of UTC time) to be displayed.

The latitude and longitude under the cursor are shown along with the distance (and direction) from the
ground station in APT images.

Information can be optionally displayed on the images in a selectable size font and €bisuran be
automated and can include the name of the satellite, time and location of the pass along yvithenan
details related to the satellite and image.

Tear-off menus are supported-his allows easier selection of enhancements and options throughmsindo
which are alvays on screen. This option is natadable on MacOS X.

Provides support for the control of the FT-8x7, PCR100/PCR1000/PCR1500/PCR2500, SAN 200,
WRX-137, Timestep Proscan i-interface, AOR, Uniden Bearcat, ICOM, aned¢d receiers and sup-
port for a user-supplied radio control program (see website for more details).

Allows the program to be configured to automatically enter record/decode mode at the start of a satellite
pass for completely automated recording.

In addition, future work will focus on features only for users wheaetmrchased the standard edition.
Neither the standard edition nor the fkaee edition can be used for commercial purposes.

What additional features are enabled when | purchase the Professional Edition *?
The Professional Edition provides all the features of the Standard Edition, plus:

allows for an on-image temperature scale for thermal and sea surface temperature enhancements,
provides a choice of resample algorithms (for geographic transformation),
provides additional noise filter options,
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provides additional contrast options, and

provides detailed controlver which sensor is used for illumination with HYCT and HVC enhancements,
and

can be used for commercial purposes.
* specifications subject to change without notice, see website for current details.

Thank You
in advance for your upgrade at:
http://www.wxtoimg.com/reg/

Copyright
Copyright (c) 2001-2010 Central North Publishing Limited. All rights reserved.
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